iptables: fix install rule to install everything in appropriate directories
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Thu, 18 Sep 2008 11:08:27 +0000 (11:08 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Thu, 18 Sep 2008 11:08:27 +0000 (11:08 -0000)
This patch will install iptables with the install-strip command, and also use
/usr/lib as target for the filter libraries.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/iptables/iptables.mk

index 43f02827acc8501d154a87fe5911fbd065686d77..5cc98e2a1b652acbeb7546c75f5bde1cc4507ec4 100644 (file)
@@ -7,14 +7,13 @@ IPTABLES_VERSION = 1.4.1
 IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
 IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables
 
-IPTABLES_INSTALL_STAGING = NO
+IPTABLES_CONF_OPT = --libexecdir=/usr/lib
 IPTABLES_INSTALL_TARGET = YES
-IPTABLES_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-exec-am
+IPTABLES_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-strip
 
 IPTABLES_AUTORECONF = YES
-IPTABLES_DEPENDENCIES = 
-IPTABLES_CONFIGURE_OPT = --with-kernel=$(LINUX_HEADERS_DIR) 
+IPTABLES_DEPENDENCIES =
+IPTABLES_CONFIGURE_OPT = --with-kernel=$(LINUX_HEADERS_DIR)
 IPTABLES_MAKE_OPT = GLIB_GENMARSHAL=/usr/bin/glib-genmarshal GLIB_MKENUMS=/usr/bin
 
 $(eval $(call AUTOTARGETS,package,iptables))
-