fbdump: only build VGA16 support on x86/x86-64
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Sep 2012 10:03:33 +0000 (10:03 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 20 Sep 2012 12:49:57 +0000 (14:49 +0200)
The VGA16 dumping feature probably doesn't make much sense on anything
else than x86 and x86-64, as it is accessing I/O ports that seem
PC-specific.

Moreover, some architectures such as SH4, do not have an
implementation of outw() in uClibc, but we quite certainly don't care
about VGA16 support for such architectures.

Fixes:

  http://autobuild.buildroot.org/results/e1c860830dd585830cf5ca5f935b81856e992334/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/fbdump/fbdump.mk

index 3ca10bf1e5d8e01dc0e8cbdd49de1a5b18f79ade..820ae9682ceb43a2fa536ebfc79b877b882789c4 100644 (file)
@@ -9,4 +9,13 @@ FBDUMP_SITE:=http://www.rcdrummond.net/fbdump
 FBDUMP_LICENSE = GPLv2
 FBDUMP_LICENSE_FILES = COPYING
 
+# The VGA16 specific feature of fbdump doesn't make much sense outside
+# of the x86/x86-64 architectures, and causes build problems on some
+# architectures as outw() is not always available.
+ifeq ($(BR2_i386)$(BR2_x86_64),y)
+FBDUMP_CONF_OPT += --enable-vga16fb
+else
+FBDUMP_CONF_OPT += --disable-vga16fb
+endif
+
 $(eval $(autotools-package))