icu: remove BR2_ARCH_HAS_ATOMICS dependency
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Jan 2016 23:07:51 +0000 (00:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 26 Jan 2016 20:26:08 +0000 (21:26 +0100)
The BR2_ARCH_HAS_ATOMICS was added because on ARC, atomic instructions
may not be provided by the architecture and therefore the compiler
does not provide the __sync_*() built-ins.

However, since then, icu was changed and is now able to use C++11
atomics, or even no atomic operations at all. In fact, icu will:

 * If possible, it will use C++11 atomics, which internally rely on
   the __atomic built-ins. These are available since gcc 4.7, and all
   architectures provide it. On some architectures, you *must* link
   with libatomic, on some other architectures, they are available
   built-in, but in all cases, linking against libatomic does not
   harm. Thanks to this, even ARC with no atomic support (which was
   the original reason for adding the BR2_ARCH_HAS_ATOMICS) dependency
   builds fine, provided -latomic is added to LIBS.

 * If C++11 atomics are not available, then it falls back to
   __sync_*() built-ins, which allows compilers older than 4.7 to be
   supported.

 * If really no atomic mechanism is available, then it falls back to a
   basic implementation based on a mutex.

Conclusion:

 - The BR2_ARCH_HAS_ATOMICS dependency is no longer needed.

 - We need to link with -latomic when gcc >= 4.7 is used.

Note that reverse dependencies of icu are also changed accordingly.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/beecrypt/Config.in
package/cppcms/Config.in
package/icu/Config.in
package/icu/icu.mk
package/php/Config.ext
package/qt-webkit-kiosk/Config.in
package/qt5/qt5base/Config.in
package/qt5/qt5webkit/Config.in

index fc93a7760560c9d1f7086aa17272fbdf202e8c66..069f3d5cfd4d2c9c2e70351cd2ed956a4d2fdb70 100644 (file)
@@ -16,7 +16,6 @@ config BR2_PACKAGE_BEECRYPT_CPP
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR # icu
        depends on !BR2_BINFMT_FLAT # icu
-       depends on BR2_ARCH_HAS_ATOMICS # icu
        depends on !BR2_STATIC_LIBS
        select BR2_PACKAGE_ICU
        help
@@ -24,7 +23,6 @@ config BR2_PACKAGE_BEECRYPT_CPP
 
 comment "C++ support needs a toolchain w/ C++, wchar, dynamic libraries"
        depends on !BR2_BINFMT_FLAT
-       depends on BR2_ARCH_HAS_ATOMICS
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR \
                || BR2_STATIC_LIBS
 
index 85ba1182392b1c8466b35b3d1535dddeb9b1da9e..79f54741ba7871dec579dc730c7da279f17a872c 100644 (file)
@@ -26,7 +26,6 @@ if BR2_PACKAGE_CPPCMS
 config BR2_PACKAGE_CPPCMS_ICU
        bool "enable icu support"
        depends on !BR2_BINFMT_FLAT # icu
-       depends on BR2_ARCH_HAS_ATOMICS # icu
        select BR2_PACKAGE_ICU
        help
          Using ICU allows advanced localization features into CppCMS,
index 4d47c32540524d1e6f9db93694b4f69a2e86ea53..d31c1fa3dcff9e0514673da819f82681d14bd5f3 100644 (file)
@@ -7,7 +7,6 @@ config BR2_PACKAGE_ICU
        # file, and it cannot easily be changed to generate FLAT
        # format.
        depends on !BR2_BINFMT_FLAT
-       depends on BR2_ARCH_HAS_ATOMICS
        help
          International Components for Unicode.
 
@@ -28,6 +27,5 @@ endif
 
 comment "icu needs a toolchain w/ C++, wchar, threads"
        depends on !BR2_BINFMT_FLAT
-       depends on BR2_ARCH_HAS_ATOMICS
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
                !BR2_TOOLCHAIN_HAS_THREADS
index 5604504896cd879691a7fe9e820a447e46dd2fbe..7bc7f938ecb9c6183b57562b8c4093f753492554 100644 (file)
@@ -17,6 +17,14 @@ ICU_CONF_OPTS = \
        --with-cross-build=$(HOST_ICU_DIR)/source \
        --disable-samples \
        --disable-tests
+
+# With gcc >= 4.7, icu prefers to use C++11 atomics, which rely on the
+# __atomic builtins. On certain architectures, this requires linking
+# with libatomic.
+ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_4_7),y)
+ICU_CONF_ENV += LIBS="-latomic"
+endif
+
 HOST_ICU_CONF_OPTS = \
        --disable-samples \
        --disable-tests \
index c044e45ad849c6057f68be2e31c6fa6e0c165dfe..ee51030ab74c37debdb0f027a2a4d686af4effe6 100644 (file)
@@ -207,13 +207,11 @@ config BR2_PACKAGE_PHP_EXT_INTL
        depends on BR2_USE_WCHAR
        depends on !BR2_BINFMT_FLAT # icu
        depends on BR2_TOOLCHAIN_HAS_THREADS # icu
-       depends on BR2_ARCH_HAS_ATOMICS # icu
        help
          Internationalization support
 
 comment "intl support needs a toolchain w/ C++, wchar, threads"
        depends on !BR2_BINFMT_FLAT
-       depends on BR2_ARCH_HAS_ATOMICS
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
 
 config BR2_PACKAGE_PHP_EXT_MBSTRING
index 51383f0a0796019723362c9c58a6db45a060a51c..32952d7c50d88418b4c9cb4fde1be3f48201fc1e 100644 (file)
@@ -8,7 +8,6 @@ config BR2_PACKAGE_QT_WEBKIT_KIOSK
        select BR2_PACKAGE_QT5MULTIMEDIA
        depends on !BR2_STATIC_LIBS # qt5webkit
        depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE # qt5webkit
-       depends on BR2_ARCH_HAS_ATOMICS # qt5webkit
        depends on !BR2_BINFMT_FLAT # qt5webkit
        help
          Simple kiosk-mode browser powered by Qt5Webkit
index 7cadcb2b89138d42e00b371332c48be35d544b61..64a7f653861403a7fa24ebf9b2d676824ff4a6aa 100644 (file)
@@ -259,7 +259,6 @@ config BR2_PACKAGE_QT5BASE_DBUS
 config BR2_PACKAGE_QT5BASE_ICU
        bool "Enable ICU support"
        select BR2_PACKAGE_ICU
-       depends on BR2_ARCH_HAS_ATOMICS # icu
        depends on !BR2_BINFMT_FLAT # icu
        help
          This option enables ICU support in Qt5. This is for example
index eee82e8df6af7eec45e96cf03616fad3e9e17c41..96d97cc8d1a540870b6fc7ddd41f5ba3f706a25f 100644 (file)
@@ -9,7 +9,6 @@ config BR2_PACKAGE_QT5WEBKIT
        # This module does not support static linking
        depends on !BR2_STATIC_LIBS
        depends on BR2_PACKAGE_QT5_JSCORE_AVAILABLE
-       depends on BR2_ARCH_HAS_ATOMICS # icu
        depends on !BR2_BINFMT_FLAT # icu
        help
          Qt is a cross-platform application and UI framework for