boost: add target build step
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 5 Dec 2015 14:35:46 +0000 (15:35 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 5 Dec 2015 14:38:05 +0000 (15:38 +0100)
The build step for the target was missing, causing the compilation to happen
during the staging install step.  Add a dedicated build step like we do for
the host build.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/boost/boost.mk

index b96969d66294971799c5e08849900b5a705b52ac..6a2e925cb3ba651a3f3b62cfa18bb8bc60a18245 100644 (file)
@@ -128,6 +128,14 @@ define BOOST_CONFIGURE_CMDS
        echo "" >> $(@D)/user-config.jam
 endef
 
+define BOOST_BUILD_CMDS
+       (cd $(@D) && ./bjam -j$(PARALLEL_JOBS) -q \
+       --user-config=$(@D)/user-config.jam \
+       $(BOOST_OPTS) \
+       --ignore-site-config \
+       --layout=$(BOOST_LAYOUT))
+endef
+
 define BOOST_INSTALL_TARGET_CMDS
        (cd $(@D) && ./b2 -j$(PARALLEL_JOBS) -q \
        --user-config=$(@D)/user-config.jam \