package/jasper: work around gcc bug 85180
authorGiulio Benetti <giulio.benetti@micronovasrl.com>
Tue, 21 May 2019 13:39:28 +0000 (15:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 May 2019 19:53:09 +0000 (21:53 +0200)
With Microblaze Gcc version < 8.x the build hangs due to gcc bug
85180: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85180. The bug
shows up when building jasper with optimization but not when building
with -O0. To work around this, if BR2_TOOLCHAIN_HAS_GCC_BUG_85180=y,
we force using -O0.

Fixes:

  http://autobuild.buildroot.net/results/5546087cdf684099525dc5824ed428cd0fd74283/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
[Thomas: tweak CFLAGS logic, improve commit log]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/jasper/jasper.mk

index b544a7c1c686a59755590d5f92f3ac9a59d8ae98..31fded779b3a8f1163abf96193afec302dfddc6e 100644 (file)
@@ -25,4 +25,12 @@ else
 JASPER_CONF_OPTS += -DJAS_ENABLE_LIBJPEG=OFF
 endif
 
+JASPER_CFLAGS = $(TARGET_CFLAGS)
+
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
+JASPER_CFLAGS += -O0
+endif
+
+JASPER_CONF_OPTS += -DCMAKE_C_FLAGS="$(JASPER_CFLAGS)"
+
 $(eval $(cmake-package))