Make busybox config file location a config option
authorEric Andersen <andersen@codepoet.org>
Tue, 12 Apr 2005 20:32:45 +0000 (20:32 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 12 Apr 2005 20:32:45 +0000 (20:32 -0000)
package/busybox/Config.in
package/busybox/busybox.mk
target/device/AMD/DBAu1500/Makefile.in
target/device/Soekris/Makefile.in

index 320cb9b1c076e24d27603a21795159311803bf0c..c9b0badf3b443976b5f92a48d12da84a247490ce 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_PACKAGE_BUSYBOX
-       bool "busybox"
+       bool "BusyBox"
        default y
        help
          The Swiss Army Knife of embedded Linux.  It slices, it dices, it
@@ -10,10 +10,21 @@ config BR2_PACKAGE_BUSYBOX
          Most people will answer Y.
 
 config BR2_PACKAGE_BUSYBOX_SNAPSHOT
-       bool "Use the daily snapshot of busybox?"
+       bool "Use the daily snapshot of BusyBox?"
        depends BR2_PACKAGE_BUSYBOX
        default y
        help
-         Use the latest busybox CVS snapshot instead of release.
+         Use the latest BusyBox daily snapshot instead of release.
 
          For fun, you should say Y.
+
+config BR2_PACKAGE_BUSYBOX_CONFIG
+       string "BusyBox configuration file to use?"
+       depends BR2_PACKAGE_BUSYBOX
+       default "package/busybox/busybox.config"
+       help
+         Some people may wish to use their own modified BusyBox configuration
+         file, and will specify their config file location with this option.
+
+         Most people will just use the default BusyBox configuration file.
+
index 0013f4a74f2d15b78097137646cac43cd35980b2..e090feb6dcb5b1a518ba1b656769b65f90efa4ee 100644 (file)
@@ -16,7 +16,9 @@ BUSYBOX_SOURCE:=busybox-$(BUSYBOX_VER).tar.bz2
 BUSYBOX_SITE:=http://www.busybox.net/downloads
 endif
 BUSYBOX_UNZIP=bzcat
-BUSYBOX_CONFIG_FILE=package/busybox/busybox.config
+
+BUSYBOX_CONFIG_FILE=$(subst ",, $(strip $(BR2_PACKAGE_BUSYBOX_CONFIG)))
+#"
 
 $(DL_DIR)/$(BUSYBOX_SOURCE):
         $(WGET) -P $(DL_DIR) $(BUSYBOX_SITE)/$(BUSYBOX_SOURCE)
index 675034df943245a5d7b58c8d8574e2115fa93f20..f08df8fdcc6984b12ff4a4f0410f06ba2180b68a 100644 (file)
@@ -1,6 +1,6 @@
 ALCHEMY_DBAU1500_PATH=target/device/AMD/DBAu1500
 
-BUSYBOX_CONFIG=$(ALCHEMY_DBAU1500_PATH)/busybox.config
+BR2_PACKAGE_BUSYBOX_CONFIG=$(ALCHEMY_DBAU1500_PATH)/busybox.config
 UCLIBC_CONFIG_FILE=$(ALCHEMY_DBAU1500_PATH)/uClibc.config.$(ARCH)
 
 TARGET_SKELETON=$(ALCHEMY_DBAU1500_PATH)/skel.tar.gz
index 8f9fc24cc5ff87572cd957df8c232c4a414dee3b..55efdd38eaf4282351b2f07f29e4451d725baad6 100644 (file)
@@ -1,7 +1,7 @@
 # Override the default uClibc configuration
 ifeq ($(strip $(BR2_TARGET_SOEKRIS_NET4521)),y)
 UCLIBC_CONFIG_FILE:=target/device/Soekris/net4521/uClibc.config
-BUSYBOX_CONFIG:=target/device/Soekris/net4521/busybox.config
+BR2_PACKAGE_BUSYBOX_CONFIG:=target/device/Soekris/net4521/busybox.config
 
 ifeq ($(strip $(BR2_PACKAGE_LINUX)),y)
 include target/device/Soekris/net4521/linux.mk