package/systemd: add optional iptables dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 3 Feb 2019 18:04:16 +0000 (19:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 4 Feb 2019 10:25:26 +0000 (11:25 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk

index 15db1969e5454210a01c32592abb3622f7c6771e..f9df66b03919eab0d71ba4c49dbd7fbf247549d8 100644 (file)
@@ -64,6 +64,13 @@ else
 SYSTEMD_CONF_OPTS += -Delfutils=false
 endif
 
+ifeq ($(BR2_PACKAGE_IPTABLES),y)
+SYSTEMD_DEPENDENCIES += iptables
+SYSTEMD_CONF_OPTS += -Dlibiptc=true
+else
+SYSTEMD_CONF_OPTS += -Dlibiptc=false
+endif
+
 # Both options can't be selected at the same time so prefer libidn2
 ifeq ($(BR2_PACKAGE_LIBIDN2),y)
 SYSTEMD_DEPENDENCIES += libidn2