package/jimtcl: fix fallout after no-C++ fixups
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 31 Mar 2018 07:20:19 +0000 (09:20 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 31 Mar 2018 07:25:51 +0000 (09:25 +0200)
Commit 4cd1ab158 (core: alternate solution to disable C++) made use of a
non-existent 'no' binary when C++ is not available in the toolchain.

However, some packages, like jimtcl, really want to find the binary that
$CXX contains.

Revert jimtcl to use 'false' instead of 'no'.

Fixes:
    http://autobuild.buildroot.org/results/54f/54f3df03551fbdf293d33dc1e3f08005faa15321/

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/jimtcl/jimtcl.mk

index 68c8a914db884e4c5af415231c8be6b345012278..389a72ab8300cefe5ba6522729a3321a70d9e71b 100644 (file)
@@ -44,9 +44,13 @@ endif
 # pkg-autotools.mk
 JIMTCL_POST_PATCH_HOOKS += UPDATE_CONFIG_HOOK
 
+# jimtcl really wants to find a existing $CXX, so feed it false
+# when we do not have one.
 define JIMTCL_CONFIGURE_CMDS
        (cd $(@D); \
-               $(TARGET_CONFIGURE_OPTS) CCACHE=none \
+               $(TARGET_CONFIGURE_OPTS) \
+               CCACHE=none \
+               $(if $(BR2_INSTALL_LIBSTDCPP),,CXX=false) \
                ./configure --prefix=/usr \
                --host=$(GNU_TARGET_NAME) \
                --build=$(GNU_HOST_NAME) \