package/dovecot: add linux-pam optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 11 Jul 2019 16:58:38 +0000 (18:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Jul 2019 16:45:20 +0000 (18:45 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/bba0d54cab164d77caf7161596b22602875a7a85

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dovecot/dovecot.mk

index e4573e63f44a7587615a3c559976abea030f7f7b..5a04b314ec4a91be1abd48e254eac9a5aa4e367f 100644 (file)
@@ -64,6 +64,13 @@ else
 DOVECOT_CONF_OPTS += --without-sodium
 endif
 
+ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
+DOVECOT_CONF_OPTS += --with-pam
+DOVECOT_DEPENDENCIES += linux-pam
+else
+DOVECOT_CONF_OPTS += --without-pam
+endif
+
 ifeq ($(BR2_PACKAGE_DOVECOT_MYSQL),y)
 DOVECOT_CONF_ENV += MYSQL_CONFIG="$(STAGING_DIR)/usr/bin/mysql_config"
 DOVECOT_CONF_OPTS += --with-mysql