package/pdbg: bump version to v2.3
authorJoel Stanley <joel@jms.id.au>
Wed, 2 Oct 2019 02:56:52 +0000 (12:26 +0930)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 2 Oct 2019 19:18:41 +0000 (21:18 +0200)
Drop the endian.h patch has this has been fixed upstream.

Signed-off-by: Joel Stanley <joel@jms.id.au>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pdbg/0001-src-thread.c-include-endian.h.patch [deleted file]
package/pdbg/pdbg.hash
package/pdbg/pdbg.mk

diff --git a/package/pdbg/0001-src-thread.c-include-endian.h.patch b/package/pdbg/0001-src-thread.c-include-endian.h.patch
deleted file mode 100644 (file)
index b7ee09a..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From e6a903ce82392c59d653f870a8af57d263c83a4f Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Fri, 2 Aug 2019 12:28:42 +0200
-Subject: [PATCH] src/thread.c: include endian.h
-
-endian.h is needed for be64oh otherwise build with musl fails on:
-
-src/thread.c: In function 'flip_endian':
-src/thread.c:49:9: error: implicit declaration of function 'be64toh' [-Werror=implicit-function-declaration]
-  return be64toh(v);
-
-Fixes:
- - http://autobuild.buildroot.org/results/81b1107bdb06250e1a7837506aec0c9762e771c5
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/open-power/pdbg/pull/43]
----
- src/thread.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/thread.c b/src/thread.c
-index 7fd53a8..7ead430 100644
---- a/src/thread.c
-+++ b/src/thread.c
-@@ -18,6 +18,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <assert.h>
-+#include <endian.h>
- #include <libpdbg.h>
--- 
-2.20.1
-
index b856e4ce8c0ce235c646ca8039b694f19cf3a3c3..68c7735e19d766fb858f90dd547093e4edca6650 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 b3bd93475da1e68502732309fa274514fb0a1193d574adfd68d5feeabeb30571  pdbg-2.2.tar.gz
+sha256 dffeb0774dd2600b384bb42903fbbbff1396eb078f3430d129fec10ca194a4bb pdbg-2.3.tar.gz
 sha256 cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30 COPYING
index 97832f23d189c8802cfca4ad7fb982d3a7a03bc6..52eaddb0b436cc31077c1a07d0aa13d7300ab550 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-PDBG_VERSION = 2.2
+PDBG_VERSION = 2.3
 PDBG_SITE = $(call github,open-power,pdbg,v$(PDBG_VERSION))
 PDBG_LICENSE = Apache-2.0
 PDBG_LICENSE_FILES = COPYING