x264: fix build on OpenRISC
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Mar 2017 13:45:50 +0000 (14:45 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 5 Mar 2017 20:35:27 +0000 (21:35 +0100)
Even though x264 doesn't use an autoconf generated configure script
(and hence doesn't use the autotools-package infrastructure), it uses
config.guess and config.sub. The ones bundled in x264 are too old to
know about the OpenRISC architecture, so this commit leverages the
UPDATE_CONFIG_HOOK from the autotools-package infrastructure to update
config.sub and config.guess.

Fixes:

  http://autobuild.buildroot.net/results/b458c2dff0ecde61248f058092c6eeaa75039cfb

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x264/x264.mk

index 80437c408c016bd0dceae043903f9ecfdafe7ea7..2c8040b85e249f31b46cd22ffd48601abad4374d 100644 (file)
@@ -36,6 +36,11 @@ ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
 X264_CONF_OPTS += --disable-thread
 endif
 
+# Even though the configure script is not generated by autoconf, x264
+# uses config.sub/config.guess, so we want up-to-date versions of
+# them.
+X264_POST_PATCH_HOOKS += UPDATE_CONFIG_HOOK
+
 # the configure script is not generated by autoconf
 define X264_CONFIGURE_CMDS
        (cd $(@D); $(TARGET_CONFIGURE_OPTS) $(X264_CONF_ENV) ./configure \