easy-rsa: new package
authorJulien Viard de Galbert <julien@vdg.name>
Mon, 29 May 2017 21:03:39 +0000 (23:03 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Jul 2017 22:24:38 +0000 (00:24 +0200)
[Peter: Mention that openssl is a runtime dependency,
Add license info as noted by Romain, add gpl-2.0.txt,
Add comment explaining the missing build step,
Use install -t for x509-types files]
Signed-off-by: Julien Viard de Galbert <julien@vdg.name>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/easy-rsa/Config.in [new file with mode: 0644]
package/easy-rsa/easy-rsa.hash [new file with mode: 0644]
package/easy-rsa/easy-rsa.mk [new file with mode: 0644]

index d121bd8163712f3bb1a5ca316479473efeb18a9b..22016a50dc5d52f4c16cc35e03d4d7466e398ffe 100644 (file)
@@ -969,6 +969,7 @@ F:  package/lldpd/
 
 N:     Julien Viard de Galbert <julien@vdg.name>
 F:     package/dieharder/
+F:     package/easy-rsa/
 
 N:     Justin Maggard <jmaggard@netgear.com>
 F:     package/dtach/
index 355aa5201da03872559830afd8ae12bf53695d49..4c7852d1138ecf5c3ea9add2c4434d5bd9d263e7 100644 (file)
@@ -1803,6 +1803,7 @@ comment "Utilities"
        source "package/dialog/Config.in"
        source "package/dtach/Config.in"
        source "package/file/Config.in"
+       source "package/easy-rsa/Config.in"
        source "package/gnupg/Config.in"
        source "package/gnupg2/Config.in"
        source "package/inotify-tools/Config.in"
diff --git a/package/easy-rsa/Config.in b/package/easy-rsa/Config.in
new file mode 100644 (file)
index 0000000..883d679
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_EASY_RSA
+       bool "easy-rsa"
+       select BR2_PACKAGE_OPENSSL # runtime
+       select BR2_PACKAGE_OPENSSL_BIN
+       help
+         Simple shell based CA utility
+
+         This package eases the creation of certificates, for example
+         for openvpn clients.
+
+         This was formerly part of the openvpn package.
+
+         easy-rsa is a wrapper script around OpenSSL binaries.
+
+         https://github.com/OpenVPN/easy-rsa
diff --git a/package/easy-rsa/easy-rsa.hash b/package/easy-rsa/easy-rsa.hash
new file mode 100644 (file)
index 0000000..e2d658a
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed: (after verifying gpg sig)
+sha512 d20f646e33ec803444dfcd446553f1d6001227fedec93280c212b34cccee11b184599f1b2ae6a3ce9cf6c9ac52f2b840ebb645536df6ddf55382fa25c22df81f EasyRSA-3.0.1.tgz
diff --git a/package/easy-rsa/easy-rsa.mk b/package/easy-rsa/easy-rsa.mk
new file mode 100644 (file)
index 0000000..8ed5741
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# easy-rsa
+#
+################################################################################
+
+EASY_RSA_VERSION = 3.0.1
+EASY_RSA_SOURCE = EasyRSA-$(EASY_RSA_VERSION).tgz
+EASY_RSA_SITE = https://github.com/OpenVPN/easy-rsa/releases/download/$(EASY_RSA_VERSION)
+EASY_RSA_LICENSE = GPL-2.0
+EASY_RSA_LICENSE_FILES = COPYING gpl-2.0.txt
+
+# shell script, so no build step
+
+define EASY_RSA_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/easyrsa $(TARGET_DIR)/usr/bin/easyrsa
+       $(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/easy-rsa/x509-types
+       $(INSTALL) -m 0644 -t $(TARGET_DIR)/etc/easy-rsa/x509-types $(@D)/x509-types/*
+       $(INSTALL) -D -m 0644 $(@D)/openssl-1.0.cnf $(TARGET_DIR)/etc/easy-rsa/openssl-1.0.cnf
+       $(INSTALL) -D -m 0644 $(@D)/vars.example $(TARGET_DIR)/etc/easy-rsa/vars
+endef
+
+$(eval $(generic-package))