u-boot: add support for u-boot-nand.bin
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 1 Dec 2011 15:04:58 +0000 (12:04 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 1 Dec 2011 15:50:05 +0000 (16:50 +0100)
Add support for the u-boot-nand.bin target file.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/uboot/Config.in
boot/uboot/uboot.mk

index dd49a2c230e131af1a52a186531a623471362d28..f154bd1233da3d2390e08c3efd82980903d4f408 100644 (file)
@@ -85,6 +85,9 @@ choice
 config BR2_TARGET_UBOOT_FORMAT_BIN
        bool "u-boot.bin"
 
+config BR2_TARGET_UBOOT_FORMAT_NAND_BIN
+       bool "u-boot-nand.bin"
+
 config BR2_TARGET_UBOOT_FORMAT_KWB
        depends on BR2_arm
        bool "u-boot.kwb (Marvell)"
index cf223121134b5e92bd961a0e01ec8ab149f5d244..db9de8d3cd37d05714fd73a0d8a8116741c3e48c 100644 (file)
@@ -27,6 +27,8 @@ UBOOT_BIN          = u-boot.kwb
 UBOOT_MAKE_TARGET  = $(UBOOT_BIN)
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_LDR),y)
 UBOOT_BIN          = u-boot.ldr
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)
+UBOOT_BIN          = u-boot-nand.bin
 else
 UBOOT_BIN          = u-boot.bin
 endif