package: set CXX to false rather than "" if no C++ support is enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 May 2009 19:19:59 +0000 (21:19 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 May 2009 19:22:44 +0000 (21:22 +0200)
Some configure scripts seems to ignore CXX settings if it is set to
the empty string, and goes back to the default (<arch>-linux-g++),
so use false instead, as that will loudly break the build if the
C++ compiler is ever used.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in

index 2605639c9e1176c9528b5c2f10207c5654a155be..7daa3b40404f3dd065bd90dbdaf96d6e49b6e6d1 100644 (file)
@@ -371,7 +371,7 @@ DISABLE_IPV6= --disable-ipv6
 endif
 
 ifneq ($(BR2_GCC_CROSS_CXX),y)
-TARGET_CONFIGURE_OPTS+=CXX=""
+TARGET_CONFIGURE_OPTS+=CXX=false
 endif
 
 ifeq ($(BR2_ENABLE_DEBUG),y)