package: add librsync
authorChris Seawood <cls@seawood.org>
Mon, 22 Mar 2010 15:50:51 +0000 (16:50 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 22 Mar 2010 16:27:13 +0000 (17:27 +0100)
Closes #1303

[Peter: misc tweaks (whitespace, kconfig, sf.net URL)]

Signed-off-by: Chris Seawood <cls@seawood.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/librsync/Config.in [new file with mode: 0644]
package/librsync/librsync.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 1b909940f96d646c099bb5d7d5b9d8221086eae9..d7927cfd8712d8125227bb91269dc1e6c5abfc76 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -5,6 +5,8 @@
 
        X.org updated to 7.5.
 
+       New packages: librsync
+
        Updated/fixed packages: busybox, dosfstools, e2fsprogs, iperf,
        libglib2, libpng, memstat, mtd-utils, pppd, setserial,
        squashfs, wget
@@ -15,6 +17,7 @@
        #1111: Bump wget to 1.12 and migrate to Makefile.autotools.in
        #1129: Bump memstat to 0.8 and migrate to Makefile.package.in
        #1273: BR2_INET_IPV6 does not enable IPv6 in pppd
+       #1303: Add librsync package
        #1345: Bump pppd to 2.4.5 and convert to Makefile.autotools.in
 
 2010.02, Release February 26th, 2010:
index 5dc7c8d5ec65549c4116bef63c991c016e27b04e..9f56c60eb1e99329a58b727c5944c23bcb3b0347 100644 (file)
@@ -81,6 +81,7 @@ source "package/libiconv/Config.in"
 source "package/libidn/Config.in"
 source "package/liblockfile/Config.in"
 source "package/liboil/Config.in"
+source "package/librsync/Config.in"
 source "package/libsysfs/Config.in"
 source "package/lockfile-progs/Config.in"
 source "package/logrotate/Config.in"
diff --git a/package/librsync/Config.in b/package/librsync/Config.in
new file mode 100644 (file)
index 0000000..5dcdfc8
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBRSYNC
+       bool "librsync"
+       select BR2_PACKAGE_ZLIB
+       select BR2_PACKAGE_BZIP2
+       select BR2_PACKAGE_POPT
+       help
+         librsync implements the rolling-checksum algorithm of
+         remote file synchronization that was popularized by the
+         rsync utility and is used in rproxy.
+
+         http://sourceforge.net/projects/librsync/
diff --git a/package/librsync/librsync.mk b/package/librsync/librsync.mk
new file mode 100644 (file)
index 0000000..3db4625
--- /dev/null
@@ -0,0 +1,15 @@
+#############################################################
+#
+# librsync
+#
+#############################################################
+LIBRSYNC_VERSION:=0.9.7
+LIBRSYNC_SOURCE:=librsync-$(LIBRSYNC_VERSION).tar.gz
+LIBRSYNC_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/librsync/
+LIBRSYNC_INSTALL_STAGING = YES
+LIBRSYNC_INSTALL_TARGET = YES
+LIBRSYNC_CONF_OPT = --enable-shared
+
+LIBRSYNC_DEPENDENCIES = zlib bzip2 popt
+
+$(eval $(call AUTOTARGETS,package,librsync))