package/mkpaswd: define extract step to allow patching
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 26 Apr 2021 21:46:27 +0000 (23:46 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 28 Apr 2021 21:44:33 +0000 (23:44 +0200)
As recently discussed on the list:
http://lists.busybox.net/pipermail/buildroot/2021-April/308373.html

Packages like mkpasswd where the source code is included in the Buildroot
tree, currently doesn't use an extract step (which also skips the patch
step), so they cannot be patched by a patch in BR2_GLOBAL_PATCH_DIR (or the
pkgdir), which is a bit confusing.

As a fix, add a simple extract step that copies the source files to the
build directory, so the patch step gets run as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mkpasswd/mkpasswd.mk

index b013390572261e94e3577e1bf05102ea85f5df0a..c1117ef65c721cabe1dea47c75806e62b7989143 100644 (file)
@@ -9,9 +9,13 @@
 # at revision 5a0f08500fa51608b6d3b73ee338be38c692eadb
 HOST_MKPASSWD_LICENSE = GPL-2.0+
 
+define HOST_MKPASSWD_EXTRACT_CMDS
+       cp $(HOST_MKPASSWD_PKGDIR)/*.c $(HOST_MKPASSWD_PKGDIR)/*.h $(@D)
+endef
+
 define HOST_MKPASSWD_BUILD_CMDS
        $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) \
-               package/mkpasswd/mkpasswd.c package/mkpasswd/utils.c \
+               $(@D)/mkpasswd.c $(@D)/utils.c \
                -o $(@D)/mkpasswd -lcrypt
 endef