stunnel: bump to version 5.07
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 5 Nov 2014 16:01:59 +0000 (13:01 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 6 Nov 2014 08:12:24 +0000 (09:12 +0100)
Also enable optional systemd support.

[Peter: fixup announcement url in .hash as pointed out by Baruch]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/stunnel/stunnel.hash
package/stunnel/stunnel.mk

index 89af57120cec38f98a687992439b8aa503d49109..2745a81bdfccef42c8dfc3b9c6fba2e31f2d3eab 100644 (file)
@@ -1,2 +1,2 @@
-# From http://www.stunnel.org/pipermail/stunnel-announce/2014-October/000084.html
-sha256 098c2b6db0793ea4fa5b6767ce6ef1853e9f6cc2f32133024be55f6a460b1a40        stunnel-5.06.tar.gz
+# From http://www.stunnel.org/pipermail/stunnel-announce/2014-November/000085.html
+sha256 505c6c63c4a20fc0cce8c35ef1ab7626c7b01071e3fca4ac6ea417afe8065309        stunnel-5.07.tar.gz
index 7be0cc7ff6f6848087c55f24abedfc77ec76ae9b..dc5626165c70cdb542887fc4d5b1f7fa25803d72 100644 (file)
@@ -4,13 +4,20 @@
 #
 ################################################################################
 
-STUNNEL_VERSION = 5.06
+STUNNEL_VERSION = 5.07
 STUNNEL_SITE = http://ftp.nluug.nl/pub/networking/stunnel/archive/5.x
 STUNNEL_DEPENDENCIES = openssl
-STUNNEL_CONF_OPTS = --with-ssl=$(STAGING_DIR)/usr --with-threads=fork
+STUNNEL_CONF_OPTS = --with-ssl=$(STAGING_DIR)/usr --with-threads=fork \
+       --disable-libwrap
 STUNNEL_LICENSE = GPLv2+
 STUNNEL_LICENSE_FILES = COPYING COPYRIGHT.GPL
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+STUNNEL_DEPENDENCIES += systemd
+else
+STUNNEL_CONF_OPTS += --disable-systemd
+endif
+
 define STUNNEL_INSTALL_CONF_SCRIPT
        $(INSTALL) -m 0755 -D package/stunnel/S50stunnel $(TARGET_DIR)/etc/init.d/S50stunnel
        [ -f $(TARGET_DIR)/etc/stunnel/stunnel.conf ] || \