libpjsip: depend on libsrtp
authorLuca Ceresoli <luca@lucaceresoli.net>
Tue, 8 Mar 2016 23:06:41 +0000 (00:06 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 9 Mar 2016 06:31:27 +0000 (07:31 +0100)
libpjsip needs libsrtp to build, but it bundles a libsrtp version in
case one is not found during the configure step. The Buildroot policy
in such cases is to force using the external package, so forcibly
depend on libsrtp.

Adding --with-external-srtp also fixes libpjsip not correctly the
libsrtp installed in staging, which shows up with the symptom:

  .../libpjmedia.so: undefined reference to `srtp_deinit'
  collect2: error: ld returned 1 exit status

Fixes:
  http://autobuild.buildroot.org/results/305/305fdc8442cd2e8f51b90485be0dca83ffa36603/
  http://autobuild.buildroot.org/results/a2f/a2f407c1361ac5c24af122445e84645e9aee309d/
  ...and many other similar autobuild failures.

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libpjsip/Config.in
package/libpjsip/libpjsip.mk

index 980fada3d5fb36c9029322f5f96592edd02c2e73..727d2ec3d06c1dae8f4630bd9efc498b9086692d 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_LIBPJSIP
        bool "libpjsip"
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_LIBSRTP
        help
          PJSIP is a free and open source multimedia communication
          library written in C language implementing standard based
index ee250f5b11ef0ef8b87d61ba3072caf0f210b4bf..49abd744e59d5a6e7b5442fe40f5cb6df6e359c6 100644 (file)
@@ -7,6 +7,7 @@
 LIBPJSIP_VERSION = 2.4.5
 LIBPJSIP_SOURCE = pjproject-$(LIBPJSIP_VERSION).tar.bz2
 LIBPJSIP_SITE = http://www.pjsip.org/release/$(LIBPJSIP_VERSION)
+LIBPJSIP_DEPENDENCIES = libsrtp
 LIBPJSIP_LICENSE = GPLv2+
 LIBPJSIP_LICENSE_FILES = COPYING
 LIBPJSIP_INSTALL_STAGING = YES
@@ -22,7 +23,8 @@ LIBPJSIP_CONF_OPTS = \
        --disable-speex-aec \
        --disable-resample \
        --disable-video \
-       --disable-opencore-amr
+       --disable-opencore-amr \
+       --with-external-srtp=$(STAGING_DIR)/usr
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBPJSIP_DEPENDENCIES += openssl