sdl2_ttf: new package
authorPeter Thompson <peter.macleod.thompson@gmail.com>
Tue, 12 Jul 2016 14:53:05 +0000 (08:53 -0600)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 Jul 2016 14:34:20 +0000 (16:34 +0200)
Signed-off-by: Peter Thompson <peter.macleod.thompson@gmail.com>
[Thomas:
 - point <pkg>_LICENSE_FILES to a file that actually exists
 - add host-pkgconf to the dependencies
 - remove unneeded CONF_OPTS options
 - pass FREETYPE_CONFIG in the environment to point to freetype-config]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/sdl2_ttf/Config.in [new file with mode: 0644]
package/sdl2_ttf/sdl2_ttf.hash [new file with mode: 0644]
package/sdl2_ttf/sdl2_ttf.mk [new file with mode: 0644]

index 5be20532fc143c645d91579fce872156df55e0a3..da7b8555e3df17a56a71cf38415120c4260f5a98 100644 (file)
@@ -265,6 +265,7 @@ comment "Graphic libraries"
        source "package/sdl2/Config.in"
        source "package/sdl2_gfx/Config.in"
        source "package/sdl2_image/Config.in"
+       source "package/sdl2_ttf/Config.in"
 
 comment "Other GUIs"
        source "package/qt/Config.in"
diff --git a/package/sdl2_ttf/Config.in b/package/sdl2_ttf/Config.in
new file mode 100644 (file)
index 0000000..cb77059
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_SDL2_TTF
+       bool "SDL2_TTF"
+       depends on BR2_PACKAGE_SDL2
+       select BR2_PACKAGE_FREETYPE
+       help
+         SDL2_ttf is a sample TrueType font library. It allows you to
+         use TrueType fonts in your SDL2 applications.
+
+         http://www.libsdl.org/projects/SDL_ttf/
diff --git a/package/sdl2_ttf/sdl2_ttf.hash b/package/sdl2_ttf/sdl2_ttf.hash
new file mode 100644 (file)
index 0000000..515189a
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 34db5e20bcf64e7071fe9ae25acaa7d72bdc4f11ab3ce59acc768ab62fe39276  SDL2_ttf-2.0.14.tar.gz
diff --git a/package/sdl2_ttf/sdl2_ttf.mk b/package/sdl2_ttf/sdl2_ttf.mk
new file mode 100644 (file)
index 0000000..71c5bc7
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# sdl2_ttf
+#
+################################################################################
+
+SDL2_TTF_VERSION = 2.0.14
+SDL2_TTF_SOURCE = SDL2_ttf-$(SDL2_TTF_VERSION).tar.gz
+SDL2_TTF_SITE = http://www.libsdl.org/projects/SDL_ttf/release
+SDL2_TTF_LICENSE = zlib
+SDL2_TTF_LICENSE_FILES = COPYING.txt
+SDL2_TTF_INSTALL_STAGING = YES
+SDL2_TTF_DEPENDENCIES = sdl2 freetype host-pkgconf
+SDL2_TTF_CONF_ENV = \
+       FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
+
+$(eval $(autotools-package))