nfs-utils: add host package
authorBaruch Siach <baruch@tkos.co.il>
Wed, 23 May 2018 17:44:46 +0000 (20:44 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 May 2018 21:24:30 +0000 (23:24 +0200)
We only need the host package for the rpcgen utility. glibc deprecated
this utility in version 2.26. Fedora has recently removed rpcgen from
its glibc package. So we need to build the rpcgen from the nfs-utils
package.

The removal of Sun RPC from glibc also removed RPC headers from glibc.
rpcgen needs two of these headers. Add host-libtirpc to provide the RPC
headers.

Tested-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nfs-utils/nfs-utils.mk

index 26112d69f2305de60e1dc351e365f2906aa01ac9..9fa7ae200b578726869b04889c18b17669c7c462 100644 (file)
@@ -24,6 +24,20 @@ NFS_UTILS_CONF_OPTS = \
        --with-statedir=/run/nfs \
        --with-rpcgen=internal
 
+HOST_NFS_UTILS_CONF_OPTS = \
+       --disable-nfsv4 \
+       --disable-nfsv41 \
+       --disable-gss \
+       --disable-uuid \
+       --disable-ipv6 \
+       --without-tcp-wrappers \
+       --with-statedir=/run/nfs \
+       --disable-caps \
+       --disable-tirpc \
+       --without-systemd \
+       --with-rpcgen=internal
+HOST_NFS_UTILS_DEPENDENCIES = host-pkgconf host-libtirpc
+
 NFS_UTILS_TARGETS_$(BR2_PACKAGE_NFS_UTILS_RPCDEBUG) += usr/sbin/rpcdebug
 NFS_UTILS_TARGETS_$(BR2_PACKAGE_NFS_UTILS_RPC_LOCKD) += usr/sbin/rpc.lockd
 NFS_UTILS_TARGETS_$(BR2_PACKAGE_NFS_UTILS_RPC_RQUOTAD) += usr/sbin/rpc.rquotad
@@ -89,4 +103,13 @@ endef
 # nfsiostat is interpreted python, so remove it unless it's in the target
 NFS_UTILS_POST_INSTALL_TARGET_HOOKS += $(if $(BR2_PACKAGE_PYTHON),,NFS_UTILS_REMOVE_NFSIOSTAT)
 
+define HOST_NFS_UTILS_BUILD_CMDS
+       $(MAKE) -C $(@D)/tools/rpcgen
+endef
+
+define HOST_NFS_UTILS_INSTALL_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/tools/rpcgen/rpcgen $(HOST_DIR)/bin/rpcgen
+endef
+
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))