linux: add support for 4.x versions
authorSébastien Szymanski <sebastien.szymanski@armadeus.com>
Tue, 24 Feb 2015 13:40:46 +0000 (14:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 27 Feb 2015 15:14:27 +0000 (16:14 +0100)
Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk

index 29f59e882e05ce036aa3db9b6e9ff7118b67d602..0b8c9121f366da5bc83c47af78a192ab9de183d0 100644 (file)
@@ -25,12 +25,14 @@ LINUX_SITE_METHOD = hg
 else
 LINUX_SOURCE = linux-$(LINUX_VERSION).tar.xz
 # In X.Y.Z, get X and Y. We replace dots and dashes by spaces in order
-# to use the $(word) function. We support versions such as 3.1,
+# to use the $(word) function. We support versions such as 4.0, 3.1,
 # 2.6.32, 2.6.32-rc1, 3.0-rc6, etc.
 ifeq ($(findstring x2.6.,x$(LINUX_VERSION)),x2.6.)
 LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v2.6
-else
+else ifeq ($(findstring x3.,x$(LINUX_VERSION)),x3.)
 LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v3.x
+else ifeq ($(findstring x4.,x$(LINUX_VERSION)),x4.)
+LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v4.x
 endif
 # release candidates are in testing/ subdir
 ifneq ($(findstring -rc,$(LINUX_VERSION)),)