package/qt5/qt5multimedia: fix gstreamer1 support
authorBenoît Thébaudeau <benoit@wsystem.com>
Thu, 27 Aug 2015 16:34:14 +0000 (18:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 27 Aug 2015 18:24:18 +0000 (20:24 +0200)
Fix the missing gstreamer1 build dependencies, which could possibly
prevent the configuration of qt5multimedia from detecting the supported
gstreamer1 features.

Fix the missing gstreamer1 install rules, which resulted in the
following runtime error:

    defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"

Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5multimedia/qt5multimedia.mk

index 763fc28603d865c1301fda239364130cb58df48f..50fdd57a7a74823602781b8395c0db7bf4c5615b 100644 (file)
@@ -21,6 +21,9 @@ endif
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
 QT5MULTIMEDIA_DEPENDENCIES += gst-plugins-base
 endif
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
+QT5MULTIMEDIA_DEPENDENCIES += gst1-plugins-base
+endif
 
 ifeq ($(BR2_PACKAGE_QT5DECLARATIVE),y)
 QT5MULTIMEDIA_DEPENDENCIES += qt5declarative
@@ -40,7 +43,7 @@ define QT5MULTIMEDIA_INSTALL_STAGING_CMDS
 endef
 
 ifeq ($(BR2_STATIC_LIBS),)
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
+ifneq ($(BR2_PACKAGE_GST_PLUGINS_BASE)$(BR2_PACKAGE_GST1_PLUGINS_BASE),)
 define QT5MULTIMEDIA_INSTALL_TARGET_QGSTTOOLS_LIB
        cp -dpf $(STAGING_DIR)/usr/lib/libqgsttools*.so.* $(TARGET_DIR)/usr/lib
 endef