fs/ubifs: allow extra options to be passed to ubifs creation tools
authorMark Jackson <mpfj-list@newflow.co.uk>
Wed, 24 Apr 2013 02:29:19 +0000 (02:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 25 Apr 2013 20:43:13 +0000 (22:43 +0200)
Allow extra options to be passed to ubifs creation tools.

Signed-off-by: Mark Jackson <mpfj@newflow.co.uk>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/ubifs/Config.in
fs/ubifs/ubi.mk
fs/ubifs/ubifs.mk

index 0a798d861f107b61fe4b029f8cb125dd409d6796..d716fc08860b24279bb99f2450082f7224524709 100644 (file)
@@ -87,6 +87,12 @@ config BR2_TARGET_ROOTFS_UBIFS_XZ
 
 endchoice
 
+config BR2_TARGET_ROOTFS_UBIFS_OPTS
+       string "Additional mkfs.ubifs options"
+       depends on BR2_TARGET_ROOTFS_UBIFS
+       help
+         Any additional mkfs.ubifs options you may want to include.
+
 config BR2_TARGET_ROOTFS_UBI
        depends on BR2_TARGET_ROOTFS_UBIFS
        bool "Embed into an UBI image"
@@ -108,3 +114,9 @@ config BR2_TARGET_ROOTFS_UBI_SUBSIZE
        help
          Tells ubinize that the flash supports sub-pages and the sub-page
          size. Use 0 if subpages are not supported on flash chip.
+
+config BR2_TARGET_ROOTFS_UBI_OPTS
+       string "Additional ubinize options"
+       depends on BR2_TARGET_ROOTFS_UBI
+       help
+         Any additional ubinize options you may want to include.
index 51ab42d15c344b53d4c1b82d4a9b39c49c457d65..e9033e8741eafc7ec5e75b5b44a16d1bbb8d62bf 100644 (file)
@@ -10,6 +10,8 @@ ifneq ($(BR2_TARGET_ROOTFS_UBI_SUBSIZE),0)
 UBI_UBINIZE_OPTS += -s $(BR2_TARGET_ROOTFS_UBI_SUBSIZE)
 endif
 
+UBI_UBINIZE_OPTS += $(call qstrip,$(BR2_TARGET_ROOTFS_UBI_OPTS))
+
 ROOTFS_UBI_DEPENDENCIES = rootfs-ubifs
 
 define ROOTFS_UBI_CMD
index 8506dbdb8dec08877f1dbb9e690ec3eca7c2b3dc..dca2e04fb8544c4332cfa06d94a78d2d1270408b 100644 (file)
@@ -16,10 +16,12 @@ ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_NONE),y)
 UBIFS_OPTS += -x none
 endif
 
+UBIFS_OPTS += $(call qstrip,$(BR2_TARGET_ROOTFS_UBIFS_OPTS))
+
 ROOTFS_UBIFS_DEPENDENCIES = host-mtd
 
 define ROOTFS_UBIFS_CMD
        $(HOST_DIR)/usr/sbin/mkfs.ubifs -d $(TARGET_DIR) $(UBIFS_OPTS) -o $@
 endef
 
-$(eval $(call ROOTFS_TARGET,ubifs))
\ No newline at end of file
+$(eval $(call ROOTFS_TARGET,ubifs))