Enable xapp_bdftopcf dependencies for the host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 6 May 2010 18:07:29 +0000 (20:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 6 May 2010 18:18:42 +0000 (20:18 +0200)
Now that xapp_bdftopcf is enabled on the host, we also need its
dependencies to be available for the host. The dependency of
host-xapp_bdftopcf is host-xlib_libXfont, which itself depends on a
bunch of other packages. Some of them were already available for the
host, some not (xfont_encodings, xlib_xtrans, xproto_fontcacheproto,
xproto_fontsproto) and are therefore added by this patch.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/xfont_encodings/xfont_encodings.mk
package/x11r7/xlib_libXfont/xlib_libXfont.mk
package/x11r7/xlib_xtrans/xlib_xtrans.mk
package/x11r7/xproto_fontcacheproto/xproto_fontcacheproto.mk
package/x11r7/xproto_fontsproto/xproto_fontsproto.mk

index 20a192b3c9582e2890eb444040831bae4d818e30..ed94e49bd3077a828ebda3fecf70e6691fda53fd 100644 (file)
@@ -10,5 +10,7 @@ XFONT_ENCODINGS_SITE = http://xorg.freedesktop.org/releases/individual/font
 XFONT_ENCODINGS_AUTORECONF = NO
 XFONT_ENCODINGS_MAKE_OPT =
 XFONT_ENCODINGS_DEPENDENCIES = host-xapp_mkfontscale
+HOST_XFONT_ENCODINGS_DEPENDENCIES = host-xapp_mkfontscale
 
 $(eval $(call AUTOTARGETS,package/x11r7,xfont_encodings))
+$(eval $(call AUTOTARGETS,package/x11r7,xfont_encodings,host))
index df4ececd42c44a940926b539c4738df959067a1b..3cb52c3b0dcbbac5e1ed049b4f17ceaa4ef4c61a 100644 (file)
@@ -12,4 +12,7 @@ XLIB_LIBXFONT_INSTALL_STAGING = YES
 XLIB_LIBXFONT_DEPENDENCIES = freetype xlib_libfontenc xlib_xtrans xproto_fontcacheproto xproto_fontsproto xproto_xproto xfont_encodings
 XLIB_LIBXFONT_CONF_OPT = --enable-shared --disable-static --disable-devel-docs
 
+HOST_XLIB_LIBXFONT_DEPENDENCIES = host-freetype host-xlib_libfontenc host-xlib_xtrans host-xproto_fontcacheproto host-xproto_fontsproto host-xproto_xproto host-xfont_encodings
+
 $(eval $(call AUTOTARGETS,package/x11r7,xlib_libXfont))
+$(eval $(call AUTOTARGETS,package/x11r7,xlib_libXfont,host))
index 0968bdf0aa1a24c27411c94adbf2cc761ac809e9..aaf220836669efaa3223d58fa0cc2752c53fe5b4 100644 (file)
@@ -11,3 +11,4 @@ XLIB_XTRANS_AUTORECONF = NO
 XLIB_XTRANS_INSTALL_STAGING = YES
 
 $(eval $(call AUTOTARGETS,package/x11r7,xlib_xtrans))
+$(eval $(call AUTOTARGETS,package/x11r7,xlib_xtrans,host))
index 9c2ef4777f1cd46400aec5ecfd2256cab7bf2f11..40917cd8047a42b99e236702a3fce77d5a9a0925 100644 (file)
@@ -12,3 +12,4 @@ XPROTO_FONTCACHEPROTO_INSTALL_STAGING = YES
 XPROTO_FONTCACHEPROTO_INSTALL_TARGET = NO
 
 $(eval $(call AUTOTARGETS,package/x11r7,xproto_fontcacheproto))
+$(eval $(call AUTOTARGETS,package/x11r7,xproto_fontcacheproto,host))
index dc18399c63dddcd4395675ea929f187bdd37f45b..5e2a64a600c27779b170ea3b836d23dd6a4495a3 100644 (file)
@@ -12,3 +12,4 @@ XPROTO_FONTSPROTO_INSTALL_STAGING = YES
 XPROTO_FONTSPROTO_INSTALL_TARGET = NO
 
 $(eval $(call AUTOTARGETS,package/x11r7,xproto_fontsproto))
+$(eval $(call AUTOTARGETS,package/x11r7,xproto_fontsproto,host))