xbmc: add host-nasm dependency
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 7 Jun 2014 12:31:03 +0000 (14:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Jun 2014 12:58:37 +0000 (14:58 +0200)
Fixes:
checking for nasm... no
configure: error: Could not find a required program. Please see the README for your platform.

This will be needed for 13.0 Gotham.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xbmc/xbmc.mk

index d8b9508befc70bf596e95592d5eb5eb2c9e045e5..35228026fcfeb40bc381ce726db58268b8d6508a 100644 (file)
@@ -18,6 +18,9 @@ XBMC_DEPENDENCIES += boost bzip2 expat flac fontconfig freetype jasper jpeg \
        libogg libplist libpng libsamplerate libungif libvorbis libxml2 lzo ncurses \
        openssl pcre python readline sqlite taglib tiff tinyxml yajl zlib
 
+# xbmc@i386 depends on nasm
+XBMC_DEPENDENCIES += $(if $(BR2_i386),host-nasm)
+
 XBMC_CONF_ENV = \
        PYTHON_VERSION="$(PYTHON_VERSION_MAJOR)" \
        PYTHON_LDFLAGS="-lpython$(PYTHON_VERSION_MAJOR) -lpthread -ldl -lutil -lm" \