rpi-userland: systemd support
authorAlex Suykov <alex.suykov@gmail.com>
Sat, 23 May 2015 10:07:07 +0000 (13:07 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 13:53:15 +0000 (15:53 +0200)
[Thomas: use relative path for the symbolic link.]

Signed-off-by: Alex Suykov <alex.suykov@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rpi-userland/rpi-userland.mk
package/rpi-userland/vcfiled.service [new file with mode: 0644]

index 1a1c9c6fac7794095089f767a599db33a7e36505..e2eadb2850f38583eddda918e984d87fc1bf210e 100644 (file)
@@ -19,6 +19,13 @@ define RPI_USERLAND_INSTALL_INIT_SYSV
        $(INSTALL) -m 0755 -D package/rpi-userland/S94vcfiled \
                $(TARGET_DIR)/etc/init.d/S94vcfiled
 endef
+define RPI_USERLAND_INSTALL_INIT_SYSTEMD
+       $(INSTALL) -D -m 644 package/rpi-userland/vcfiled.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/vcfiled.service
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+       ln -sf ../../../../usr/lib/systemd/system/vcfiled.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/vcfiled.service
+endef
 endif
 
 define RPI_USERLAND_POST_TARGET_CLEANUP
diff --git a/package/rpi-userland/vcfiled.service b/package/rpi-userland/vcfiled.service
new file mode 100644 (file)
index 0000000..2b8f1dc
--- /dev/null
@@ -0,0 +1,8 @@
+[Unit]
+Description=VideoCore file server daemon
+
+[Service]
+ExecStart=/usr/sbin/vcfiled --foreground
+
+[Install]
+WantedBy=multi-user.target