package/mplayer: add optional lzo support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Mar 2015 17:11:26 +0000 (19:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 8 Apr 2015 20:59:25 +0000 (22:59 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index 14e8c77eed0bb12bfa70501ea10ef014421a28cf..c8f4dd359068ab8a5f982fadcd3c34ffc745bdec 100644 (file)
@@ -159,6 +159,13 @@ else
 MPLAYER_CONF_OPTS += --disable-gif
 endif
 
+ifeq ($(BR2_PACKAGE_LZO),y)
+MPLAYER_DEPENDENCIES += lzo
+MPLAYER_CONF_OPTS += --enable-liblzo
+else
+MPLAYER_CONF_OPTS += --disable-liblzo
+endif
+
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBTHEORA),libtheora)
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBPNG),libpng)
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_JPEG),jpeg)