lsof: don't use host toolchain to determine target libc
authorBaruch Siach <baruch@tkos.co.il>
Wed, 14 May 2014 12:45:08 +0000 (15:45 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 15 May 2014 21:39:15 +0000 (23:39 +0200)
The lsof Configure script builds a test program using the host toolchain to
test whether glibc is used. This test is broken in cross compilation
environment. Set LINUX_CLIB to avoid the test. This should give the correct
result even for non glibc toolchains, since all libc variants we support have
the netinet/tcp.h header.

Fixes:
http://autobuild.buildroot.net/results/a1f/a1f0572dbf968c21f70b35cefff7ef7a1d9a348a/

Cc: Benoît Thébaudeau <benoit.thebaudeau@advansee.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/lsof/lsof.mk

index f4b1b4cb8f867696bc599046c0aa632798854826..332d1f83a5dfa5db9de37db41507b2ec3baac170 100644 (file)
@@ -49,7 +49,8 @@ endef
 define LSOF_CONFIGURE_CMDS
        (cd $(@D) ; \
                echo n | $(TARGET_CONFIGURE_OPTS) DEBUG="$(TARGET_CFLAGS) $(BR2_LSOF_CFLAGS)" \
-               LSOF_INCLUDE="$(STAGING_DIR)/usr/include" LSOF_CFLAGS_OVERRIDE=1 ./Configure linux)
+               LSOF_INCLUDE="$(STAGING_DIR)/usr/include" LSOF_CFLAGS_OVERRIDE=1 \
+               LINUX_CLIB=-DGLIBCV=2 ./Configure linux)
        $(LSOF_CONFIGURE_WCHAR_FIXUPS)
        $(LSOF_CONFIGURE_LOCALE_FIXUPS)
 endef