projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
27d199a
)
package/sdl2: enable SSE only if it's supported by the target
author
Nicolas Robin
<nrosfs@gmail.com>
Fri, 15 May 2020 17:53:55 +0000
(19:53 +0200)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Fri, 15 May 2020 19:47:38 +0000
(21:47 +0200)
Signed-off-by: Nicolas Robin <nrosfs@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sdl2/sdl2.mk
patch
|
blob
|
history
diff --git
a/package/sdl2/sdl2.mk
b/package/sdl2/sdl2.mk
index 501bb4699dba33c70c7101b79f178d04b328a278..4a287b66a39d6d37c51824db461a2d6952d6af42 100644
(file)
--- a/
package/sdl2/sdl2.mk
+++ b/
package/sdl2/sdl2.mk
@@
-30,6
+30,12
@@
else
SDL2_CONF_OPTS += --disable-libudev
endif
+ifeq ($(BR2_X86_CPU_HAS_SSE),y)
+SDL2_CONF_OPTS += --enable-sse
+else
+SDL2_CONF_OPTS += --disable-sse
+endif
+
ifeq ($(BR2_PACKAGE_SDL2_DIRECTFB),y)
SDL2_DEPENDENCIES += directfb
SDL2_CONF_OPTS += --enable-video-directfb