harfbuzz: add host variant
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 19 Apr 2015 09:48:18 +0000 (06:48 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Apr 2015 12:40:14 +0000 (14:40 +0200)
Required for host-pango, which in turn is required for host-librsvg and
at last midori.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/harfbuzz/harfbuzz.mk

index 0a69b09086e30877c568d50ce706bb1520aa77f1..9cfd6130e7bb5e9c5dfbc60d0f07dd0d85826602 100644 (file)
@@ -11,6 +11,20 @@ HARFBUZZ_LICENSE = MIT, ISC (ucdn library)
 HARFBUZZ_LICENSE_FILES = COPYING src/hb-ucdn/COPYING
 HARFBUZZ_INSTALL_STAGING = YES
 HARFBUZZ_CONF_OPTS = --without-coretext --without-uniscribe --without-graphite2
+
+# freetype & glib2 support required by host-pango
+HOST_HARFBUZZ_DEPENDENCIES = \
+       host-freetype \
+       host-libglib2
+HOST_HARFBUZZ_CONF_OPTS = \
+       --without-corext \
+       --without-uniscribe \
+       --without-graphite2 \
+       --with-cairo=no \
+       --with-icu=no \
+       --with-freetype=yes \
+       --with-glib=yes
+
 # beta libtool version
 HARFBUZZ_AUTORECONF = YES
 
@@ -48,3 +62,4 @@ HARFBUZZ_CONF_OPTS += --with-icu=no
 endif
 
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))