u-boot: drop old 2009.xx versions
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 23 Feb 2011 15:46:07 +0000 (16:46 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 23 Feb 2011 15:46:07 +0000 (16:46 +0100)
We use 'make tools' to build a mkimage for the host if needed by the
kernel (uImage) without having u-boot configured, but that only works
since the 2010.03 release:

http://git.denx.de/?p=u-boot.git;a=commit;h=c7c0d542a1990

So drop the old 2009.xx versions rather than having the build break
for people.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/u-boot/Config.in
boot/u-boot/u-boot.mk

index 78c03ffb8d14d9293c9f6468fa7baec2af235881..3ba1ef3a92d79fc0277c4d0aaf6fd679f5c0d3bf 100644 (file)
@@ -28,12 +28,6 @@ config BR2_TARGET_UBOOT_2010_06
 config BR2_TARGET_UBOOT_2010_03
        bool "2010.03"
 
-config BR2_TARGET_UBOOT_2009_11
-       bool "2009.11"
-
-config BR2_TARGET_UBOOT_2009_08
-       bool "2009.08"
-
 config BR2_TARGET_UBOOT_CUSTOM_TARBALL
        bool "Custom tarball"
 
@@ -52,8 +46,6 @@ config BR2_TARGET_UBOOT_VERSION
        default "2010.09"       if BR2_TARGET_UBOOT_2010_09
        default "2010.06"       if BR2_TARGET_UBOOT_2010_06
        default "2010.03"       if BR2_TARGET_UBOOT_2010_03
-       default "2009.11"       if BR2_TARGET_UBOOT_2009_11
-       default "2009.08"       if BR2_TARGET_UBOOT_2009_08
        default "custom"        if BR2_TARGET_UBOOT_CUSTOM_TARBALL
 
 config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
index bd26f52f8aa3bb3011519bcf9b5f82342526f590..a86819b5d882c27dfffd4a9b74d5d47143d41d5f 100644 (file)
@@ -43,7 +43,7 @@ U_BOOT_TARGETS:=$(BINARIES_DIR)/$(U_BOOT_BIN) $(MKIMAGE)
 U_BOOT_ARCH=$(KERNEL_ARCH)
 
 # u-boot in the past used arch=ppc for powerpc
-ifneq ($(findstring x200,x$(U_BOOT_VERSION))$(findstring x2010.03,x$(U_BOOT_VERSION)),)
+ifneq ($(findstring x2010.03,x$(U_BOOT_VERSION)),)
 U_BOOT_ARCH=$(KERNEL_ARCH:powerpc=ppc)
 endif