wpa_supplicant: add CONFIG_AP support
authorDaniel Mack <zonque@gmail.com>
Mon, 5 Dec 2011 12:33:18 +0000 (13:33 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 7 Dec 2011 20:03:16 +0000 (21:03 +0100)
[Peter: Fix indentation]
Signed-off-by: Daniel Mack <zonque@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/wpa_supplicant/Config.in
package/wpa_supplicant/wpa_supplicant.mk

index e3df2b4d880556de28cad5a1ecd7cd96b8f15553..a4e0fba0f75bcf533d0ed231a44750deaa5cbc69 100644 (file)
@@ -23,3 +23,11 @@ config BR2_PACKAGE_WPA_SUPPLICANT_PASSPHRASE
        help
          Install wpa_passphrase command line utility
 
+config BR2_PACKAGE_WPA_SUPPLICANT_AP_SUPPORT
+       bool "Enable support for soft AP"
+       depends on BR2_PACKAGE_WPA_SUPPLICANT
+       help
+         With this option enabled, wpa_supplicant can act as
+         access point. This can be used for open and WPA2-Personal networks
+         (optionally, with WPS); this links in parts of hostapd functionality
+         into wpa_supplicant.
index b2e7be3b34d752f74311efe930594c73130db032..baa739bfdbf90b6b64ee5f0d66a2264413e9e7f8 100644 (file)
@@ -25,6 +25,16 @@ define WPA_SUPPLICANT_EAP_CONFIG
 endef
 endif
 
+ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_AP_SUPPORT),y)
+define WPA_SUPPLICANT_AP_CONFIG
+       echo "CONFIG_AP=y" >>$(WPA_SUPPLICANT_CONFIG)
+endef
+else
+define WPA_SUPPLICANT_AP_CONFIG
+       $(SED) "s/^CONFIG_AP=y//" $(WPA_SUPPLICANT_CONFIG)
+endef
+endif
+
 define WPA_SUPPLICANT_CRYPTO_CONFIG
        echo "CONFIG_CRYPTO=internal" >>$(WPA_SUPPLICANT_CONFIG)
        echo "CONFIG_INTERNAL_LIBTOMMATH=y" >>$(WPA_SUPPLICANT_CONFIG)
@@ -69,6 +79,7 @@ define WPA_SUPPLICANT_CONFIGURE_CMDS
        $(WPA_SUPPLICANT_EAP_CONFIG)
        $(WPA_SUPPLICANT_LIBNL_CONFIG)
        $(WPA_SUPPLICANT_DBUS_CONFIG)
+       $(WPA_SUPPLICANT_AP_CONFIG)
 endef
 
 define WPA_SUPPLICANT_REMOVE_CLI