toolchain-external: bump Linaro ARM to 2014.05
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 Jun 2014 10:47:42 +0000 (12:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 9 Jun 2014 13:39:24 +0000 (15:39 +0200)
The major changes are: switch to gcc 4.9 instead of 4.8, and switch to
glibc 2.19 instead of glibc 2.18.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/toolchain-external.mk

index 32e77879e56dab488c0e2b1be16eb162cc04c98d..2e7c4e99e1390e479082f47016f7f43443cafd87 100644 (file)
@@ -7,13 +7,12 @@ comment "(e)glibc toolchains only available with shared lib support"
        depends on BR2_PREFER_STATIC_LIB
 
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
-       bool "Linaro ARM 2014.02"
+       bool "Linaro ARM 2014.05"
        depends on BR2_arm
        depends on BR2_GCC_TARGET_ARCH = "armv7-a"
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        depends on BR2_ARM_EABIHF
        depends on !BR2_PREFER_STATIC_LIB
-       select BR2_TOOLCHAIN_HAS_GCC_BUG_58854 # toolchain generated before fix backport
        select BR2_TOOLCHAIN_EXTERNAL_GLIBC
        select BR2_TOOLCHAIN_HAS_NATIVE_RPC
        select BR2_INSTALL_LIBSTDCPP
@@ -21,8 +20,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
        select BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_1
        help
          Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2014.02 (based on gcc 4.8), Linaro GDB 2013.10 (based on
-         GDB 7.6), eglibc 2.18, Binutils 2014.02 (based on 2.24). It
+         GCC 2014.05 (based on gcc 4.9), Linaro GDB 2014.05 (based on
+         GDB 7.6), eglibc 2.19, Binutils 2014.05 (based on 2.24). It
          generates code that runs on all Cortex-A profile devices,
          but tuned for the Cortex-A9. The code generated is Thumb 2,
          with the hard floating point calling convention, and uses
index 1b190897ea85be4a1c947b64b92e6a9715e915ab..ba1690b087c5f8cc73a4623f5f5c78e7340c8bbc 100644 (file)
@@ -276,8 +276,8 @@ define TOOLCHAIN_EXTERNAL_FIXUP_CMDS
        rm -rf $(TOOLCHAIN_EXTERNAL_INSTALL_DIR)/arago-2011.09/
 endef
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM),y)
-TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/14.02/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.8-2014.02_linux.tar.xz
+TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/14.05/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-arm-linux-gnueabihf-4.9-2014.05_linux.tar.xz
 TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_LINARO_ARMHF_SYMLINK
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB),y)
 TOOLCHAIN_EXTERNAL_SITE = http://releases.linaro.org/14.02/components/toolchain/binaries/