opencv3: conditionally enable NEON and VFPv3 optimizations
authorMathieu Maret <mathieu.maret@gmail.com>
Thu, 7 Jun 2018 08:38:57 +0000 (10:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 7 Jun 2018 13:55:12 +0000 (15:55 +0200)
Signed-off-by: Mathieu Maret <mathieu.maret@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/opencv3/opencv3.mk

index 15e4eadfe32b2bd07799a55ac35d2dad55b57918..53b771ef2574a0e90431bd7ebc5e8d954208dbb1 100644 (file)
@@ -99,7 +99,9 @@ OPENCV3_CONF_OPTS += \
 # * PowerPC support is turned off since its only effect is altering CFLAGS,
 #   adding '-mcpu=G3 -mtune=G5' to them, which is already handled by Buildroot.
 OPENCV3_CONF_OPTS += \
-       -DENABLE_POWERPC=OFF
+       -DENABLE_POWERPC=OFF \
+       -DENABLE_NEON=$(if $(BR2_ARM_CPU_HAS_NEON),ON,OFF) \
+       -DENABLE_VFPV3=$(if $(BR2_ARM_CPU_HAS_VFPV3),ON,OFF)
 
 # Cuda stuff
 OPENCV3_CONF_OPTS += \