polarssl: security bump to version 1.2.5
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 4 Feb 2013 02:51:03 +0000 (02:51 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Feb 2013 22:22:32 +0000 (23:22 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/polarssl/polarssl-shared-and-static-library.patch
package/polarssl/polarssl.mk

index ec65285f8d7ed5e1960a548a0897cee33cad1c5e..8f7ce5f5b8e4623b16c8b9723afae30c2c8f383c 100644 (file)
@@ -9,7 +9,7 @@ This patch adds the USE_STATIC_POLARSSL_LIBRARY (which defaults to ON)
 in addition to the existing USE_SHARED_POLARSSL_LIBRARY (which
 defaults to OFF). Both options can be manipulated independently.
 
-[Gustavo: update for polarssl 1.2.3]
+[Gustavo: update for polarssl 1.2.5]
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
 
@@ -34,7 +34,7 @@ diff -Nura polarssl-1.2.3.orig/library/CMakeLists.txt polarssl-1.2.3/library/CMa
 +if(USE_SHARED_POLARSSL_LIBRARY)
  
  add_library(polarssl SHARED ${src})
- set_target_properties(polarssl PROPERTIES VERSION 1.2.3 SOVERSION 2)
+ set_target_properties(polarssl PROPERTIES VERSION 1.2.5 SOVERSION 2)
 +set_target_properties(polarssl PROPERTIES OUTPUT_NAME polarssl)
 +
 +endif(USE_SHARED_POLARSSL_LIBRARY)
index c66c633f93234767bf7c8c34a56261c9183d5136..0478f8a3de66dff30fb00b0c9ea075395e26eb39 100644 (file)
@@ -1,5 +1,5 @@
 POLARSSL_SITE = https://polarssl.org/download
-POLARSSL_VERSION = 1.2.3
+POLARSSL_VERSION = 1.2.5
 POLARSSL_SOURCE = polarssl-$(POLARSSL_VERSION)-gpl.tgz
 POLARSSL_CONF_OPT = \
        -DUSE_SHARED_POLARSSL_LIBRARY=ON \