collectd: fix option passed to the snmp dependency
authorJack Kao <jackzzjack@gmail.com>
Sun, 25 Dec 2016 13:54:34 +0000 (21:54 +0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 26 Dec 2016 08:38:42 +0000 (09:38 +0100)
--with-libnetsnmp doesn't take a path to the netsnmp config script,
but to the sysroot where netsnmp can be found.

Fixes:

  http://autobuild.buildroot.org/results/358e2f02f42e08fe362ecd46e636c0048e77c21f/

Signed-off-by: Jack Kao <jackzzjack@gmail.com>
[Thomas: path is $(STAGING_DIR)/usr, not $(STAGING_DIR)/usr/include.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/collectd/collectd.mk

index 50a2e53efaa0b53dc45f7156cf2e9a4429d0f9c1..28c1b31e0990d14476c2620a5c0b79889bec7c21 100644 (file)
@@ -162,7 +162,7 @@ ifeq ($(BR2_PACKAGE_MYSQL),y)
 COLLECTD_CONF_OPTS += --with-libmysql=$(STAGING_DIR)/usr
 endif
 ifeq ($(BR2_PACKAGE_NETSNMP),y)
-COLLECTD_CONF_OPTS += --with-libnetsnmp=$(STAGING_DIR)/usr/bin/net-snmp-config
+COLLECTD_CONF_OPTS += --with-libnetsnmp=$(STAGING_DIR)/usr
 endif
 ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
 COLLECTD_CONF_OPTS += --with-libpq=$(STAGING_DIR)/usr/bin/pg_config