librtas: bump to version 2.0.1
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 2 Jun 2018 14:43:15 +0000 (16:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 3 Jun 2018 18:26:34 +0000 (20:26 +0200)
- Switch site to github
- Move to autotools infrastructure
- Remove patch (not needed anymore)
- Since version 1.4 (January 2016), license is now LGPL-2.1+
- Add hash for license file

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/librtas/0001-librtas-install-librtas.so.1-symlink.patch [deleted file]
package/librtas/librtas.hash
package/librtas/librtas.mk

diff --git a/package/librtas/0001-librtas-install-librtas.so.1-symlink.patch b/package/librtas/0001-librtas-install-librtas.so.1-symlink.patch
deleted file mode 100644 (file)
index 2150c3f..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-Add a line to the librtas Makefile to create librtas.so.1 when
-performing "make install".
-
-Without this patch programs linked with librtas will fail at run time:
-
-error while loading shared libraries: librtas.so.1: cannot open shared
-object file: No such file or directory
-
-A patch has been submitted upstream so it is likely that this patch
-can be dropped after the next release of librtas.
-
-Signed-off-by: Sam Bobroff <sam.bobroff@au1.ibm.com>
----
- librtas_src/Makefile |    1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/librtas_src/Makefile b/librtas_src/Makefile
-index 3a10222..deba29d 100644
---- a/librtas_src/Makefile
-+++ b/librtas_src/Makefile
-@@ -33,6 +33,7 @@ install:
-       @$(call install_lib,$(LIBRTAS),$(DESTDIR))
-       @$(call install_inc,$(HEADERS),$(DESTDIR))
-       @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME)
-+      @ln -sf $(LIBRTAS) $(DESTDIR)/$(LIB_DIR)$(call is_lib64,$(LIBRTAS))/$(LIBRTAS_SONAME).1
- uninstall:
-       @$(call uninstall_lib,$(LIBRTAS),$(DESTDIR))
--- 
-1.7.10.4
-
index c81b583147647f0eb42f34f3e11d0fb4f65c4732..0f3d902226e12dd1ccbdc2a82337c0592c9a2cde 100644 (file)
@@ -1,2 +1,3 @@
 # Locally computed
-sha256 d5f2951b0934ffbd82bebf26acfa103cc21d89f4c90c7c41472acf7b4ec6d907 librtas-1.3.13.tar.gz
+sha256 a79fd9cdb2f03e7401027fb80a07f14e29b86cc2d363126d527b211fea85d025 librtas-v2.0.1.tar.gz
+sha256 592987e8510228d546540b84a22444bde98e48d03078d3b2eefcd889bec5ce8c COPYING.LESSER
index 46c4cb4bb7477d196d0cdd42b1da95f05c25308a..f89394a6af30a9bdfc7c6f2262de5b08d955356f 100644 (file)
@@ -4,22 +4,12 @@
 #
 ################################################################################
 
-LIBRTAS_VERSION = 1.3.13
-LIBRTAS_SITE = http://downloads.sourceforge.net/project/librtas
-LIBRTAS_LICENSE = Common Public License Version 1.0
-LIBRTAS_LICENSE_FILES = COPYRIGHT
+LIBRTAS_VERSION = v2.0.1
+LIBRTAS_SITE = $(call github,ibm-power-utilities,librtas,$(LIBRTAS_VERSION))
+LIBRTAS_LICENSE = LGPL-2.1+
+LIBRTAS_LICENSE_FILES = COPYING.LESSER
 LIBRTAS_INSTALL_STAGING = YES
+# From git
+LIBRTAS_AUTORECONF = YES
 
-define LIBRTAS_BUILD_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
-endef
-
-define LIBRTAS_INSTALL_STAGING_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) install
-endef
-
-define LIBRTAS_INSTALL_TARGET_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
-endef
-
-$(eval $(generic-package))
+$(eval $(autotools-package))