package/libcec: fix missing libraries from rpi-userland
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 4 Jun 2014 23:04:10 +0000 (01:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Jun 2014 13:09:58 +0000 (15:09 +0200)
When rpi-userland libraries are built as shared-objects, not all needed
libraries are passed in the LD_FLAGS, leading to failure at linkage.

To avoid this issue, set the LIBS variable content in accordance with
INCLUDES variable value.

This is needed because libcec does not use pkg-config to look for the
ldflags needed for -lbcm_host, even though bcm_host provides a .pc
file (even a correct one!)

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Samuel Martin <s.martin49@gmail.com>
Tested-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libcec/libcec.mk

index 0aabb0611ead9e732a9392215c581f373cd965da..ad919fc066c9b8081a2d0ae04d1b904ffb0cc1f1 100644 (file)
@@ -26,6 +26,7 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
 LIBCEC_CONF_OPT = --enable-rpi \
    --with-rpi-include-path=$(STAGING_DIR)/usr/include
 LIBCEC_DEPENDENCIES += rpi-userland
+LIBCEC_CONF_ENV += LIBS="-lvcos -lvchostif"
 else
 LIBCEC_CONF_OPT = --disable-rpi
 endif