binutils: build host version statically
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 Oct 2011 21:19:10 +0000 (23:19 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 Oct 2011 21:19:10 +0000 (23:19 +0200)
Otherwise we end up with libbfd/libopcodes in host/usr/$BUILD/$TARGET/lib,
used by the binaries. Unfortunately it also adds rpaths, which first look
in the build directory before here, causing trouble if the toolchain is
used outside BR (E.G. for a SDK) and the build directory location reused
for another incompatible build (E.G. another ARCH), as the binutils
binaries then end up using the wrong libs.

Fix it by linking statically instead.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/binutils/binutils.mk

index 2d60ce07476e50156f808e065ccf122385cb259d..5123568ec5bfc425a6879d62ec52ae4767b4adea 100644 (file)
@@ -30,6 +30,7 @@ endif
 # We just keep the convention of "host utility" for now
 HOST_BINUTILS_CONF_OPT = --disable-multilib --disable-werror \
                        --target=$(REAL_GNU_TARGET_NAME) \
+                       --disable-shared --enable-static \
                        $(BR2_CONFIGURE_STAGING_SYSROOT) \
                        $(BINUTILS_EXTRA_CONFIG_OPTIONS)