package/qt5base: fix qmake parallel build
authorGiulio Benetti <giulio.benetti@micronovasrl.com>
Mon, 22 Apr 2019 09:58:42 +0000 (11:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 22 Apr 2019 20:25:10 +0000 (22:25 +0200)
When configuring qt5base, qmake is built, but it's not built in parallel
mode. This is due to MAKEFLAGS having 2 dashes on its tail, so this:
MAKEFLAGS="$(MAKEFLAGS) -j$(PARALLEL_JOBS)"
expands in this(i.e. 5 njobs):
MAKEFLAGS="--no-print-directory -- -j5"
and -j5 gets ignored due to "--" preceeding -j5.
Double dashes are part of $(MAKEFLAGS) only when evaluated by shell.

Swap $(MAKEFLAGS) and -j$(PARALLEL_JOBS) to avoid having "--" before
-j$(PARALLEL_JOBS), this way -j$(PARALLEL_JOBS) won't be ignored by
./configure.

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
Tested-by: Michael Trimarchi <michael@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5base/qt5base.mk

index 0b45c50a66f4be202c060101ee5478144f915540..e73b8931aa9883e4df568a38f9b7d6c9d51ec365 100644 (file)
@@ -324,7 +324,7 @@ define QT5BASE_CONFIGURE_CMDS
        (cd $(@D); \
                $(TARGET_MAKE_ENV) \
                PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
-               MAKEFLAGS="$(MAKEFLAGS) -j$(PARALLEL_JOBS)" \
+               MAKEFLAGS="-j$(PARALLEL_JOBS) $(MAKEFLAGS)" \
                ./configure \
                -v \
                -prefix /usr \