package/transmission: Do not mark .service file executable
authorAndrey Smirnov <andrew.smirnov@gmail.com>
Thu, 24 Aug 2017 21:41:51 +0000 (14:41 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Aug 2017 14:09:57 +0000 (16:09 +0200)
Do not mark .service file executable, otherwise systemd
will give us a warning about it.

Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/transmission/transmission.mk

index f8abb2b8baea88fa3e775716abf77854cdf6e23b..0fce642a0352a6ce841ef5e2e1a355ff8e99c4ef 100644 (file)
@@ -64,7 +64,7 @@ define TRANSMISSION_INSTALL_INIT_SYSV
 endef
 
 define TRANSMISSION_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -D -m 0755 $(@D)/daemon/transmission-daemon.service \
+       $(INSTALL) -D -m 0644 $(@D)/daemon/transmission-daemon.service \
                $(TARGET_DIR)/usr/lib/systemd/system/transmission-daemon.service
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
        ln -fs ../../../../usr/lib/systemd/system/transmission-daemon.service \