olsr: fix build
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 18 Feb 2011 13:17:34 +0000 (14:17 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 18 Feb 2011 13:17:34 +0000 (14:17 +0100)
Pass TARGET_CONFIGURE_OPTS in the environment rather than as make arguments,
so the olsr build system can append to CFLAGS / LDFLAGS - Otherwise build
fails when the wrong linker flags are used to create the plugin .so's.

Also pass ARCH, so the olsr build system choses the right libdir / PIC
settings for the target, rather than for the host.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/olsr/olsr.mk

index 75d5d66ab3befc59b6f00040cb285dc3019607e9..03a8a02a0b79875c04eabfea3c1c467fc39e3871 100644 (file)
@@ -16,7 +16,7 @@ OLSR_PLUGINS=dot_draw dyn_gw secure
 OLSR_TARGET_PLUGIN=usr/lib/
 
 define OLSR_BUILD_CMDS
- $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) olsrd $(OLSR_PLUGINS)
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) ARCH=$(KERNEL_ARCH) -C $(@D) olsrd $(OLSR_PLUGINS)
 endef
 
 define OLSR_INSTALL_TARGET_CMDS