Revert "core: enable 'NDEBUG' unless BR2_ENABLE_RUNTIME_DEBUG is set"
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 4 Jul 2021 11:33:50 +0000 (13:33 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 4 Jul 2021 19:38:25 +0000 (21:38 +0200)
Enabling -DNEBUG, although correct on the paper, causes a lot of
packages to fail to build because they explicitly require not building
with NDEBUG; they use assert() to check actual runtime errors and expect
it to not be elidded away (sometimes with side effects in the arguments
passed to assert().

This reverts commit 5a8c50fe05afacc3cbe8e7347e238da9f242fab0, as
discussed on the list:
    http://lists.busybox.net/pipermail/buildroot/2021-July/313646.html

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/Makefile.in

index 955e6a8e8c72d9d468ee4bf2992d10992161a089..86db62ba5ba51f8f24bdc28d7480db5e812f4f9b 100644 (file)
@@ -148,9 +148,6 @@ endif
 ifeq ($(BR2_DEBUG_3),y)
 TARGET_DEBUGGING = -g3
 endif
-ifeq ($(BR2_ENABLE_RUNTIME_DEBUG),)
-TARGET_DEBUGGING += -DNDEBUG
-endif
 
 TARGET_LDFLAGS = $(call qstrip,$(BR2_TARGET_LDFLAGS))