jamvm: fix build with uClibc on i386/x86_64
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Nov 2016 21:19:38 +0000 (22:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Nov 2016 21:21:07 +0000 (22:21 +0100)
Commit 0b6b67f34d6d4aeb340bbca579dbf85363c3f4ea ("jamvm: add patch to
fix musl build") introduced a patch to fix the jamvm build with the
musl C library. While the commit log pretends that the build was still
working with uClibc, it is not correct: it no longer builds fine with
uClibc on i386/x86_64, because the Buildroot default configuration for
uClibc doesn't enable <fenv.h> support.

Therefore this commit adapts the patch to use <fenv.h> if available
(which is the case with musl), and otherwise fall back to
<fpu_control.h>, which is available in uClibc.

Thanks to Waldemar for the investigation.

Fixes:

  http://autobuild.buildroot.net/results/325a50d15e1836b31df4e84ba83b296abfb73041/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/jamvm/0001-Use-fenv.h-instead-of-fpu_control.h.patch [deleted file]
package/jamvm/0001-Use-fenv.h-when-available-instead-of-fpu_control.h.patch [new file with mode: 0644]
package/jamvm/jamvm.mk

diff --git a/package/jamvm/0001-Use-fenv.h-instead-of-fpu_control.h.patch b/package/jamvm/0001-Use-fenv.h-instead-of-fpu_control.h.patch
deleted file mode 100644 (file)
index 50f95cd..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-From 7152ded5219453c9ff1cd062cecbeaf4d77e4cab Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Thu, 26 May 2016 15:05:48 +0200
-Subject: [PATCH] Use <fenv.h> instead of <fpu_control.h>
-
-musl libc (http://musl-libc.org lack the non-standard <fpu_control.h>
-header, which is used in src/os/linux/{i386,x86_64}/init.c files to
-setup the floating point precision. This patch makes it use the
-standard C <fenv.h> header instead.
-
-Original patch at Felix Janda at
-https://sourceforge.net/p/jamvm/patches/6/.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- src/os/linux/i386/init.c   | 12 ++++++------
- src/os/linux/x86_64/init.c | 16 ++++++----------
- 2 files changed, 12 insertions(+), 16 deletions(-)
-
-diff --git a/src/os/linux/i386/init.c b/src/os/linux/i386/init.c
-index d9c6648..94a733e 100644
---- a/src/os/linux/i386/init.c
-+++ b/src/os/linux/i386/init.c
-@@ -19,18 +19,18 @@
-  * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-  */
--#include <fpu_control.h>
-+#include <fenv.h>
- /* Change floating point precision to double (64-bit) from
-  * the extended (80-bit) Linux default. */
- void setDoublePrecision() {
--    fpu_control_t cw;
-+    fenv_t fenv;
--    _FPU_GETCW(cw);
--    cw &= ~_FPU_EXTENDED;
--    cw |= _FPU_DOUBLE;
--    _FPU_SETCW(cw);
-+    fegetenv(&fenv);
-+    fenv.__control_word &= ~0x300; /* _FPU_EXTENDED */
-+    fenv.__control_word |= 0x200; /* _FPU_DOUBLE */
-+    fesetenv(&fenv);
- }
- void initialisePlatform() {
-diff --git a/src/os/linux/x86_64/init.c b/src/os/linux/x86_64/init.c
-index 9d55229..a76a923 100644
---- a/src/os/linux/x86_64/init.c
-+++ b/src/os/linux/x86_64/init.c
-@@ -19,9 +19,7 @@
-  * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-  */
--#ifdef __linux__
--#include <fpu_control.h>
--#endif
-+#include <fenv.h>
- /* Change the x87 FPU precision to double (64-bit) from the extended
-    (80-bit) Linux default.  Note, unlike on i386, my testcases pass
-@@ -30,14 +28,12 @@
- */
- void setDoublePrecision() {
--#ifdef __linux__
--    fpu_control_t cw;
-+    fenv_t fenv;
--    _FPU_GETCW(cw);
--    cw &= ~_FPU_EXTENDED;
--    cw |= _FPU_DOUBLE;
--    _FPU_SETCW(cw);
--#endif
-+    fegetenv(&fenv);
-+    fenv.__control_word &= ~0x300; /*_FPU_EXTENDED */
-+    fenv.__control_word |= 0x200; /*_FPU_DOUBLE */
-+    fesetenv(&fenv);
- }
- void initialisePlatform() {
--- 
-2.7.4
-
diff --git a/package/jamvm/0001-Use-fenv.h-when-available-instead-of-fpu_control.h.patch b/package/jamvm/0001-Use-fenv.h-when-available-instead-of-fpu_control.h.patch
new file mode 100644 (file)
index 0000000..78ee9b7
--- /dev/null
@@ -0,0 +1,108 @@
+From ecd4eceae98cfb1c83133bdeaa9095546ca8b7c6 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Thu, 26 May 2016 15:05:48 +0200
+Subject: [PATCH] Use <fenv.h> when available instead of <fpu_control.h>
+
+musl libc (http://musl-libc.org lack the non-standard <fpu_control.h>
+header, which is used in src/os/linux/{i386,x86_64}/init.c files to
+setup the floating point precision. This patch makes it use the
+standard C <fenv.h> header instead when available.
+
+Original patch at Felix Janda at
+https://sourceforge.net/p/jamvm/patches/6/, adapted to still use
+<fpu_control.h> if <fenv.h> is not provided.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.ac               |  2 +-
+ src/os/linux/i386/init.c   | 15 +++++++++++++++
+ src/os/linux/x86_64/init.c | 15 +++++++++++++--
+ 3 files changed, 29 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 19f77e6..ce59a3e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -279,7 +279,7 @@ fi
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(sys/time.h unistd.h endian.h sys/param.h locale.h alloca.h)
++AC_CHECK_HEADERS(sys/time.h unistd.h endian.h sys/param.h locale.h alloca.h fenv.h)
+ if test "$enable_zip" != no; then
+     AC_CHECK_HEADER(zlib.h,,AC_MSG_ERROR(zlib.h is missing))
+diff --git a/src/os/linux/i386/init.c b/src/os/linux/i386/init.c
+index d9c6648..8fefe7d 100644
+--- a/src/os/linux/i386/init.c
++++ b/src/os/linux/i386/init.c
+@@ -19,18 +19,33 @@
+  * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+  */
++#include "config.h"
++
++#if defined(HAVE_FENV_H)
++#include <fenv.h>
++#else
+ #include <fpu_control.h>
++#endif
+ /* Change floating point precision to double (64-bit) from
+  * the extended (80-bit) Linux default. */
+ void setDoublePrecision() {
++#if defined(HAVE_FENV_H)
++    fenv_t fenv;
++
++    fegetenv(&fenv);
++    fenv.__control_word &= ~0x300; /* _FPU_EXTENDED */
++    fenv.__control_word |= 0x200; /* _FPU_DOUBLE */
++    fesetenv(&fenv);
++#else
+     fpu_control_t cw;
+     _FPU_GETCW(cw);
+     cw &= ~_FPU_EXTENDED;
+     cw |= _FPU_DOUBLE;
+     _FPU_SETCW(cw);
++#endif
+ }
+ void initialisePlatform() {
+diff --git a/src/os/linux/x86_64/init.c b/src/os/linux/x86_64/init.c
+index 9d55229..b42b14e 100644
+--- a/src/os/linux/x86_64/init.c
++++ b/src/os/linux/x86_64/init.c
+@@ -19,7 +19,11 @@
+  * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+  */
+-#ifdef __linux__
++#include "config.h"
++
++#if defined(HAVE_FENV_H)
++#include <fenv.h>
++#else
+ #include <fpu_control.h>
+ #endif
+@@ -30,7 +34,14 @@
+ */
+ void setDoublePrecision() {
+-#ifdef __linux__
++#if defined(HAVE_FENV_H)
++    fenv_t fenv;
++
++    fegetenv(&fenv);
++    fenv.__control_word &= ~0x300; /*_FPU_EXTENDED */
++    fenv.__control_word |= 0x200; /*_FPU_DOUBLE */
++    fesetenv(&fenv);
++#else
+     fpu_control_t cw;
+     _FPU_GETCW(cw);
+-- 
+2.7.4
+
index b1520ada498143cd2b0f872b0c8ddbf4fe0657e7..ee80c80b2f379180bfab1fc8b3e027905197b34b 100644 (file)
@@ -9,6 +9,8 @@ JAMVM_SITE = http://downloads.sourceforge.net/project/jamvm/jamvm/JamVM%20$(JAMV
 JAMVM_LICENSE = GPLv2+
 JAMVM_LICENSE_FILES = COPYING
 JAMVM_DEPENDENCIES = zlib classpath
+# For 0001-Use-fenv.h-when-available-instead-of-fpu_control.h.patch
+JAMVM_AUTORECONF = YES
 # int inlining seems to crash jamvm, don't build shared version of internal lib
 JAMVM_CONF_OPTS = \
        --with-classpath-install-dir=/usr \
@@ -22,4 +24,11 @@ ifeq ($(BR2_arm),y)
 JAMVM_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -marm"
 endif
 
+# Needed for autoreconf
+define JAMVM_CREATE_M4_DIR
+       mkdir -p $(@D)/m4
+endef
+
+JAMVM_POST_PATCH_HOOKS += JAMVM_CREATE_M4_DIR
+
 $(eval $(autotools-package))