gamin: fix build with !BR2_LARGEFILE and python enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Nov 2009 10:42:47 +0000 (11:42 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Nov 2009 10:42:47 +0000 (11:42 +0100)
Python binding support is broken for cross compilation, disable for now.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/gamin/gamin.mk

diff --git a/CHANGES b/CHANGES
index c4779acb5947552bd2d0670ea3b08230637fae37..5defd0948299654a9e5fbf917d1b8ef3d788aea6 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        sdl_sound, swfdec, sysstat
 
        Updated/fixed packages: alsamixergui, autoconf, bootutils, busybox,
-       gcc, directfb, dnsmasq, e2fsprogs, festival, gstreamer, gst-plugins-bad,
-       gst-plugins-base, gst-plugins-good, imagemagick, ipkg, iptables,
-       iw, kernel-headers, kismet, libelf, libevent, libglib2, libidn,
-       liblockfile, libmad, libpcap, libupnp, libuuid, lighttpd, ltrace,
-       lua, lzma, magiccube4d, matchbox, mdadm, nbd, ncftp, ncurses,
+       gcc, directfb, dnsmasq, e2fsprogs, festival, gamin, gstreamer,
+       gst-plugins-bad, gst-plugins-base, gst-plugins-good, imagemagick,
+       ipkg, iptables, iw, kernel-headers, kismet, libelf, libevent, libglib2,
+       libidn, liblockfile, libmad, libpcap, libupnp, libuuid, lighttpd,
+       ltrace, lua, lzma, magiccube4d, matchbox, mdadm, nbd, ncftp, ncurses,
        netkittelnet, netsnmp, ntfs-3g, openntp, openssl, php, python, quagga,
        radvd, rsync, rubix, samba, sawman, sdl, shared-mime-info, spawn-fcgi,
        speech-tools, sqlite, squashfs, synergy, syslinux, target-binutils,
index 90b215a91222a01408d6b7aa7443e82efb49f06c..1aa5f8be0c1ffc8e0ce548f2470e88a438543b70 100644 (file)
@@ -12,9 +12,8 @@ GAMIN_INSTALL_TARGET = YES
 
 GAMIN_CONF_OPT = --program-prefix="" --disable-debug
 
-ifneq ($(BR2_PACKAGE_PYTHON),y)
+# python support broken
 GAMIN_CONF_OPT += --without-python
-endif
 
 GAMIN_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
 
@@ -22,6 +21,8 @@ GAMIN_CONF_ENV = have_abstract_sockets=no
 
 ifneq ($(BR2_LARGEFILE),y)
 GAMIN_CONF_ENV += CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
+# the above doesn't work with shared config.cache
+GAMIN_USE_CONFIG_CACHE = NO
 endif
 
 GAMIN_DEPENDENCIES = libglib2