package/asterisk: add optional libical dependency
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 9 Sep 2017 21:39:22 +0000 (23:39 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 23 Sep 2017 17:20:18 +0000 (19:20 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/asterisk/asterisk.mk

index de3a0d5291a074b14b44e48f70851cb106e085ce..921281e2602e5974ffd78b483190d9bfc9810567 100644 (file)
@@ -57,7 +57,6 @@ ASTERISK_CONF_OPTS = \
        --without-gmime \
        --without-h323 \
        --without-hoard \
-       --without-ical \
        --without-iconv \
        --without-iksemel \
        --without-imap \
@@ -149,6 +148,13 @@ else
 ASTERISK_CONF_OPTS += --without-bluetooth
 endif
 
+ifeq ($(BR2_PACKAGE_LIBICAL),y)
+ASTERISK_DEPENDENCIES += libical
+ASTERISK_CONF_OPTS += --with-ical
+else
+ASTERISK_CONF_OPTS += --without-ical
+endif
+
 ifeq ($(BR2_PACKAGE_NEON),y)
 ASTERISK_DEPENDENCIES += neon
 ASTERISK_CONF_OPTS += --with-neon