package/python-pillow: add webpmux support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 22 May 2021 17:41:58 +0000 (19:41 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 24 May 2021 08:49:36 +0000 (10:49 +0200)
webpmux is an optional dependency since version 2.2.0 and
https://github.com/python-pillow/Pillow/commit/b4735f7829bb88c99071cd91b208aa6ffd2cba24

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: move into existing webp conditional block]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/python-pillow/python-pillow.mk

index ab52f38df1d8f408fec0191123a6efd1d6aa4e64..fd0c6ce8626918b5815fa78b68ef9d518c6b6b7a 100644 (file)
@@ -59,8 +59,13 @@ endif
 ifeq ($(BR2_PACKAGE_WEBP),y)
 PYTHON_PILLOW_DEPENDENCIES += webp
 PYTHON_PILLOW_BUILD_OPTS += --enable-webp
+ifeq ($(BR2_PACKAGE_WEBP_DEMUX)$(BR2_PACKAGE_WEBP_MUX),yy)
+PYTHON_PILLOW_BUILD_OPTS += --enable-webpmux
 else
-PYTHON_PILLOW_BUILD_OPTS += --disable-webp
+PYTHON_PILLOW_BUILD_OPTS += --disable-webpmux
+endif
+else
+PYTHON_PILLOW_BUILD_OPTS += --disable-webp --disable-webpmux
 endif
 
 define PYTHON_PILLOW_BUILD_CMDS