package/blktrace: do not build in parallel
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 14 Dec 2014 16:31:07 +0000 (17:31 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 14 Dec 2014 16:49:11 +0000 (17:49 +0100)
The Makefile is not parallel safe.

Fixes numerous build failures:
    http://autobuild.buildroot.org/results/c7f/c7f0b22c6d256c75ade223af702c5f29c6c677d8/
    http://autobuild.buildroot.org/results/4ab/4abb0d2590528c634766103ee8ffd648ad5c04d3/
    ...

Look for the message:
    btreplay.o: file not recognized: File truncated

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/blktrace/blktrace.mk

index 7687ade63e1a2ca7ad196c09201867eaea62539d..8f3dbab7677dbb866666e2d348d3b73649f54c7f 100644 (file)
@@ -10,6 +10,8 @@ BLKTRACE_DEPENDENCIES = libaio
 BLKTRACE_LICENSE = GPLv2+
 BLKTRACE_LICENSE_FILES = COPYING
 
+BLKTRACE_MAKE = $(MAKE1)
+
 define BLKTRACE_BUILD_CMDS
        $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
 endef