qt: speed up qmake build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 Apr 2011 15:19:01 +0000 (17:19 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 3 Apr 2011 18:12:28 +0000 (20:12 +0200)
qmake is built during the execution of Qt ./configure script, so it is
built just with a normal make, not taking advantage of parallel
compilation. Passing MAKEFLAGS=-j$(BR2_JLEVEL) allows to speed up the
qmake compilation process quite a bit.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index 32dc574d5b13cd503cf80c66c5098487144eb4ce..8d7238eab54431db8bb70da8beb265c7a11a76d5 100644 (file)
@@ -468,7 +468,7 @@ define QT_CONFIGURE_CMDS
                PKG_CONFIG_SYSROOT_DIR="$(STAGING_DIR)" \
                PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig:$(PKG_CONFIG_PATH)" \
-               ./configure \
+               MAKEFLAGS="$(MAKEFLAGS) -j$(BR2_JLEVEL)" ./configure \
                $(if $(VERBOSE),-verbose,-silent) \
                -force-pkg-config \
                $(QT_CONFIGURE_OPTS) \