mxsldr: new package
authorErik Stromdahl <erik.stromdahl@gmail.com>
Thu, 7 Jul 2016 17:49:23 +0000 (19:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 8 Jul 2016 20:00:36 +0000 (22:00 +0200)
Signed-off-by: Erik Stromdahl <erik.stromdahl@gmail.com>
[Thomas:
 - Rename prompt from "host-mxsldr" to "host mxsldr".
 - Add BR2_armeb in the list of architectures under which this package
   can be enabled.
 - Remove double quotes around the _SITE value.
 - The license is GPLv2+, not GPLv2.
 - Add a value for the _LICENSE_FILES variable
 - Rename MXSLDR_DEPENDENCIES to HOST_MXSLDR_DEPENDENCIES, since the
   dependencies of the host package are no longer derived from the
   dependencies of the target package.
 - Remove the MXSLDR_MAKE_OPTS variable that contained the PKG_CONFIG
   variable definition: it is already passed in HOST_CONFIGURE_OPTS.
 - Remove hash file, as it is not checked on Git packages for now.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in.host
package/mxsldr/Config.in.host [new file with mode: 0644]
package/mxsldr/mxsldr.mk [new file with mode: 0644]

index 909fd967fcc24b3fd68ba1ecd07512b88d34e784..6d61f19d9af43628c30bd5a5154a89194018a6df 100644 (file)
@@ -25,6 +25,7 @@ menu "Host utilities"
        source "package/mke2img/Config.in.host"
        source "package/mtd/Config.in.host"
        source "package/mtools/Config.in.host"
+       source "package/mxsldr/Config.in.host"
        source "package/omap-u-boot-utils/Config.in.host"
        source "package/openocd/Config.in.host"
        source "package/parted/Config.in.host"
diff --git a/package/mxsldr/Config.in.host b/package/mxsldr/Config.in.host
new file mode 100644 (file)
index 0000000..a427e71
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_HOST_MXSLDR
+       bool "host mxsldr"
+       depends on BR2_arm || BR2_armeb
+       help
+         This package contains tools to download and execute code on
+         Freescale i.MX23 and i.MX28 SoC's through the Serial
+         Download Protocol.
+
+         git://git.denx.de/mxsldr.git
diff --git a/package/mxsldr/mxsldr.mk b/package/mxsldr/mxsldr.mk
new file mode 100644 (file)
index 0000000..fa7ca84
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# mxsldr
+#
+################################################################################
+
+MXSLDR_VERSION = 2793a657ab7a22487d21c1b020957806f8ae8383
+MXSLDR_SITE = git://git.denx.de/mxsldr.git
+MXSLDR_LICENSE = GPLv2+
+MXSLDR_LICENSE_FILES = COPYING
+HOST_MXSLDR_DEPENDENCIES = host-libusb host-pkgconf
+
+define HOST_MXSLDR_BUILD_CMDS
+       $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define HOST_MXSLDR_INSTALL_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/mxsldr $(HOST_DIR)/usr/bin/mxsldr
+endef
+
+$(eval $(host-generic-package))